summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2016-01-19 02:39:03 +0000
committerFelix Yan2016-01-19 02:39:03 +0000
commitbd8d6abbd700ca558547b92599563831af9e5beb (patch)
treedc41be112df9e069967e93ecee8deb48bdbafa80
parent5e41bfdee783b7392fafd435b5b907d7cf8ca1c0 (diff)
downloadaur-bd8d6abbd700ca558547b92599563831af9e5beb.tar.gz
upgpkg: 6.2.1-1
-rw-r--r--PKGBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e3e7460cf30c..eec33920b3c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,22 @@
# Maintainer: Felix Yan <felixonmars@archlinux.org>
pkgname=sopel
-pkgver=6.1.1
+pkgver=6.2.1
pkgrel=1
pkgdesc="An easy-to-use and highly extensible IRC Bot framework (Formerly Willie)"
arch=('any')
license=('custom:EFL')
url='http://sopel.chat'
-depends=('python-setuptools' 'sqlite')
-optdepends=('python-feedparser: nws and rss modules'
- 'python-pytz: remind module'
- 'python-lxml: xkcd module'
- 'python-pyenchant: spellcheck module'
- 'python-praw: reddit module'
- 'python-pygeoip: geoip module'
- 'python-xmltodict: bugzilla, currency, weather modules')
+depends=('python-setuptools' 'sqlite' 'python-xmltodict' 'python-pytz' 'python-praw'
+ 'python-pyenchant' 'python-pygeoip')
makedepends=('git' 'python-sphinx')
-checkdepends=('python-pytest' 'python-feedparser' 'python-pytz' 'python-lxml'
- 'python-pyenchant' 'python-praw' 'python-pygeoip' 'ipython'
- 'python-xmltodict')
+checkdepends=('python-pytest-runner' 'ipython')
backup=('etc/sopel.cfg')
source=("git+https://github.com/sopel-irc/sopel.git#tag=$pkgver")
md5sums=('SKIP')
prepare() {
- sed -e 's|willie|sopel|g' -e 's|Willie|Sopel|g' -i sopel/contrib/willie{.cfg,.service,.conf}
+ sed -e 's|willie|sopel|g' -e 's|Willie|Sopel|g' -i sopel/contrib/willie{.cfg,.conf}
}
build() {
@@ -35,7 +27,9 @@ build() {
check() {
cd "$srcdir/sopel"
- py.test --ignore build || warning "Tests failed"
+ mv build ../
+ python setup.py ptr || warning "Tests failed"
+ mv ../build ./
}
package() {
@@ -44,7 +38,7 @@ package() {
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 contrib/willie.cfg "$pkgdir/etc/sopel.cfg"
- install -Dm644 contrib/willie.service "$pkgdir/usr/lib/systemd/system/sopel.service"
+ install -Dm644 contrib/sopel.service "$pkgdir/usr/lib/systemd/system/sopel.service"
install -Dm644 contrib/willie.conf "$pkgdir/usr/lib/tmpfiles.d/sopel.conf"
install -Dm644 docs/build/man/sopel.1 "$pkgdir/usr/share/man/man1/sopel.1"
}