summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitri Merejkowsky2015-07-17 11:52:55 +0200
committerDimitri Merejkowsky2015-07-17 11:52:55 +0200
commitdc6a168edafee58d970eb6111d33dad3d0b8ed9d (patch)
tree8972736a60dd4eaa8df8950804ea218b08cd2627
downloadaur-dc6a168edafee58d970eb6111d33dad3d0b8ed9d.tar.gz
initial import
-rw-r--r--.SRCINFO27
-rw-r--r--0001-Properly-export-plugins-when-using-Qt5.patch165
-rw-r--r--PKGBUILD48
3 files changed, 240 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32dbc098cab6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = soprano-qt5-git
+ pkgdesc = A library which provides a highly usable object-oriented C++/Qt5 framework for RDF data
+ pkgver = v2.9.3.90.g3e00d37
+ pkgrel = 3
+ url = http://www.kde.org
+ arch = i686
+ arch = x86_64
+ groups = kde-git
+ license = LGPL
+ makedepends = cmake
+ makedepends = doxygen
+ makedepends = git
+ depends = qt5-base
+ depends = libiodbc
+ depends = redland
+ optdepends = virtuoso
+ provides = soprano
+ provides = soprano-qt5
+ conflicts = soprano
+ conflicts = soprano-qt5
+ source = git://anongit.kde.org/soprano
+ source = 0001-Properly-export-plugins-when-using-Qt5.patch
+ md5sums = SKIP
+ md5sums = 2b844cc3abe7574691aeb4083c5cec22
+
+pkgname = soprano-qt5-git
+
diff --git a/0001-Properly-export-plugins-when-using-Qt5.patch b/0001-Properly-export-plugins-when-using-Qt5.patch
new file mode 100644
index 000000000000..affd99473a6d
--- /dev/null
+++ b/0001-Properly-export-plugins-when-using-Qt5.patch
@@ -0,0 +1,165 @@
+From bfe4215e5c538697afa715e34f71d876dab2fece Mon Sep 17 00:00:00 2001
+From: Dimitri Merejkowsky <dmerejkowsky@aldebaran-robotics.com>
+Date: Thu, 4 Dec 2014 14:14:47 +0100
+Subject: [PATCH] Properly export plugins when using Qt5
+
+---
+ backends/redland/redlandbackend.h | 4 ++++
+ backends/sesame2/sesame2backend.h | 4 ++++
+ backends/virtuoso/virtuosobackend.h | 4 ++++
+ parsers/nquads/nquadparser.h | 5 +++++
+ parsers/raptor/raptorparser.h | 3 +++
+ serializers/nquads/nquadserializer.h | 4 ++++
+ serializers/raptor/raptorserializer.h | 4 ++++
+ 7 files changed, 28 insertions(+)
+
+diff --git a/backends/redland/redlandbackend.h b/backends/redland/redlandbackend.h
+index 51306c7..8653754 100644
+--- a/backends/redland/redlandbackend.h
++++ b/backends/redland/redlandbackend.h
+@@ -26,6 +26,7 @@
+
+ #include <QtCore/QObject>
+ #include <QtCore/QMutex>
++#include <QtCore/QtPlugin>
+
+ namespace Soprano
+ {
+@@ -35,6 +36,9 @@ namespace Soprano
+ {
+ Q_OBJECT
+ Q_INTERFACES(Soprano::Backend)
++#if QT_VERSION >= QT_VERSION_CHECK(5, 0, 0)
++ Q_PLUGIN_METADATA(IID "org.soprano.plugins.Backend/2.1")
++#endif
+
+ public:
+ BackendPlugin();
+diff --git a/backends/sesame2/sesame2backend.h b/backends/sesame2/sesame2backend.h
+index b358816..ed2602e 100644
+--- a/backends/sesame2/sesame2backend.h
++++ b/backends/sesame2/sesame2backend.h
+@@ -26,6 +26,7 @@
+
+ #include <QtCore/QObject>
+ #include <QtCore/QMutex>
++#include <QtCore/QtPlugin>
+
+
+ class JNIWrapper;
+@@ -36,6 +37,9 @@ namespace Soprano {
+ {
+ Q_OBJECT
+ Q_INTERFACES(Soprano::Backend)
++#if QT_VERSION >= QT_VERSION_CHECK(5, 0, 0)
++ Q_PLUGIN_METADATA(IID "org.soprano.plugins.Backend/2.1")
++#endif
+
+ public:
+ BackendPlugin();
+diff --git a/backends/virtuoso/virtuosobackend.h b/backends/virtuoso/virtuosobackend.h
+index b5ca547..ba651bd 100644
+--- a/backends/virtuoso/virtuosobackend.h
++++ b/backends/virtuoso/virtuosobackend.h
+@@ -26,6 +26,7 @@
+
+ #include <QtCore/QObject>
+ #include <QtCore/QMutex>
++#include <QtCore/QtPlugin>
+
+
+ namespace Soprano {
+@@ -38,6 +39,9 @@ namespace Soprano {
+ {
+ Q_OBJECT
+ Q_INTERFACES(Soprano::Backend)
++#if QT_VERSION >= QT_VERSION_CHECK(5, 0, 0)
++ Q_PLUGIN_METADATA(IID "org.soprano.plugins.Backend/2.1")
++#endif
+
+ public:
+ BackendPlugin();
+diff --git a/parsers/nquads/nquadparser.h b/parsers/nquads/nquadparser.h
+index a4fa7f9..d681d3d 100644
+--- a/parsers/nquads/nquadparser.h
++++ b/parsers/nquads/nquadparser.h
+@@ -24,6 +24,7 @@
+
+ #include <QtCore/QUrl>
+ #include <QtCore/QObject>
++#include <QtCore/QtPlugin>
+
+ #include "parser.h"
+ #include "statement.h"
+@@ -35,6 +36,10 @@ namespace Soprano {
+ {
+ Q_OBJECT
+ Q_INTERFACES(Soprano::Parser)
++#if QT_VERSION >= QT_VERSION_CHECK(5, 0, 0)
++ Q_PLUGIN_METADATA(IID "org.soprano.plugins.Parser/1.0")
++#endif
++
+
+ public:
+ NQuadParser();
+diff --git a/parsers/raptor/raptorparser.h b/parsers/raptor/raptorparser.h
+index bed94d1..e50a52b 100644
+--- a/parsers/raptor/raptorparser.h
++++ b/parsers/raptor/raptorparser.h
+@@ -36,6 +36,9 @@ namespace Soprano {
+ class Parser : public QObject, public Soprano::Parser {
+ Q_OBJECT
+ Q_INTERFACES(Soprano::Parser)
++#if QT_VERSION >= QT_VERSION_CHECK(5, 0, 0)
++ Q_PLUGIN_METADATA(IID "org.soprano.plugins.Parser/1.0")
++#endif
+
+ public:
+ Parser();
+diff --git a/serializers/nquads/nquadserializer.h b/serializers/nquads/nquadserializer.h
+index 5f9b34e..811bd67 100644
+--- a/serializers/nquads/nquadserializer.h
++++ b/serializers/nquads/nquadserializer.h
+@@ -24,6 +24,7 @@
+
+ #include <QtCore/QUrl>
+ #include <QtCore/QObject>
++#include <QtCore/QtPlugin>
+
+ #include "serializer.h"
+ #include "node.h"
+@@ -35,6 +36,9 @@ namespace Soprano {
+ {
+ Q_OBJECT
+ Q_INTERFACES(Soprano::Serializer)
++#if QT_VERSION >= QT_VERSION_CHECK(5, 0, 0)
++ Q_PLUGIN_METADATA(IID "org.soprano.plugins.Serializer/1.0")
++#endif
+
+ public:
+ NQuadSerializer();
+diff --git a/serializers/raptor/raptorserializer.h b/serializers/raptor/raptorserializer.h
+index 4a8426b..b3605ba 100644
+--- a/serializers/raptor/raptorserializer.h
++++ b/serializers/raptor/raptorserializer.h
+@@ -25,6 +25,7 @@
+
+ #include <QtCore/QUrl>
+ #include <QtCore/QObject>
++#include <QtCore/QtPlugin>
+
+ #include "serializer.h"
+
+@@ -34,6 +35,9 @@ namespace Soprano {
+ {
+ Q_OBJECT
+ Q_INTERFACES(Soprano::Serializer)
++#if QT_VERSION >= QT_VERSION_CHECK(5, 0, 0)
++ Q_PLUGIN_METADATA(IID "org.soprano.plugins.Serializer/1.0")
++#endif
+
+ public:
+ Serializer();
+--
+2.1.3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba5d1f747234
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Dimitri Merejkowsky <d.merej@archlinux.org>
+
+pkgname=soprano-qt5-git
+pkgver=v2.9.3.90.g3e00d37
+pkgrel=3
+pkgdesc="A library which provides a highly usable object-oriented C++/Qt5 framework for RDF data"
+arch=('i686' 'x86_64')
+url='http://www.kde.org'
+license=('LGPL')
+depends=('qt5-base' 'libiodbc' 'redland')
+makedepends=('cmake' 'doxygen' 'git')
+optdepends=('virtuoso')
+conflicts=('soprano' 'soprano-qt5')
+provides=('soprano' 'soprano-qt5')
+groups=('kde-git')
+source=('git://anongit.kde.org/soprano'
+ '0001-Properly-export-plugins-when-using-Qt5.patch')
+md5sums=('SKIP'
+ '2b844cc3abe7574691aeb4083c5cec22')
+
+pkgver() {
+ cd soprano
+ git describe --always | sed 's|-|.|g'
+}
+
+prepare() {
+ rm -fr build
+ mkdir -p build
+
+ cd soprano
+ patch -p1 < ../0001-Properly-export-plugins-when-using-Qt5.patch
+}
+
+build() {
+ cd build
+ cmake ../soprano \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_TESTING=OFF \
+ -DQT5_BUILD=ON \
+ -DSOPRANO_DISABLE_CLUCENE_INDEX=ON
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}