summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkleintux2022-12-15 11:26:20 +0100
committerkleintux2022-12-15 11:26:20 +0100
commite28ea6b42d5258bd99e9181fcc69204b887c7be5 (patch)
tree4b5de8c67f10da554958127e927e77b66e26ced6
parente76c7cb467b40bcae2b2569412ea3a9eb547ca0b (diff)
downloadaur-e28ea6b42d5258bd99e9181fcc69204b887c7be5.tar.gz
adopted. refreshed and updated to 2.1.1)
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD26
2 files changed, 20 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea6186f4ed9c..4d3c75cbe0d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = sopwith
pkgdesc = Sidescrolling shoot 'em up game
- pkgver = 1.8.4
+ pkgver = 2.1.1
pkgrel = 1
- url = http://sdl-sopwith.sourceforge.net/
+ url = https://fragglet.github.io/sdl-sopwith/sshot.html
arch = i686
arch = x86_64
license = GPL
+ makedepends = autoconf
depends = sdl
- source = http://sourceforge.net/projects/sdl-sopwith/files/sdl_sopwith/1.8.4/sopwith-1.8.4.tar.gz
- md5sums = 4bf22bd03448506602622f466480a71c
+ source = https://github.com/fragglet/sdl-sopwith/archive/refs/tags/sdl-sopwith-2.1.1.tar.gz
+ sha256sums = 93a162f31dc0a97fbab3093042e894ac40874244a89ee2a9f7e52121d1f13565
pkgname = sopwith
-
diff --git a/PKGBUILD b/PKGBUILD
index 3de06d7a31dd..f44f9703c3c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,29 @@
-# Submitter: Stefan Husmann <stefan-husmann at t-online dot de>
-# Maintainer: John D. Corrado <jdcorrado at gmail dot com>
+# Maintainer: kleintux <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Stefan Husmann <stefan-husmann at t-online dot de>
+# Contributor: John D. Corrado <jdcorrado at gmail dot com>
+
pkgname=sopwith
-pkgver=1.8.4
+_pkgname="sdl-${pkgname}"
+pkgver=2.1.1
pkgrel=1
pkgdesc="Sidescrolling shoot 'em up game"
-url="http://sdl-sopwith.sourceforge.net/"
+url="https://fragglet.github.io/sdl-sopwith/sshot.html"
arch=('i686' 'x86_64')
license=('GPL')
depends=('sdl')
-source=(http://sourceforge.net/projects/sdl-$pkgname/files/sdl_$pkgname/$pkgver/$pkgname-$pkgver.tar.gz)
-md5sums=('4bf22bd03448506602622f466480a71c')
+makedepends=('autoconf')
+source=("https://github.com/fragglet/sdl-sopwith/archive/refs/tags/sdl-sopwith-${pkgver}.tar.gz")
+sha256sums=('93a162f31dc0a97fbab3093042e894ac40874244a89ee2a9f7e52121d1f13565')
build() {
- cd "$srcdir/$pkgname-$pkgver"
-
+ cd "${srcdir}/${_pkgname}-${_pkgname}-${pkgver}"
+ mkdir -p autotools
+ autoreconf -fi
./configure --prefix=/usr
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
-
- make DESTDIR="$pkgdir/" install
+ cd "${srcdir}/${_pkgname}-${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
}