summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYardena Cohen2020-04-09 22:02:05 -0700
committerYardena Cohen2020-04-10 01:34:39 -0700
commit0010ad0b04a1dd158af199826c1bb855644b8640 (patch)
tree37b535287029ee173f08138831064752a7f66568
parente9d0986e4f7246330e8f5e16c84ea4e21b5acdab (diff)
downloadaur-soqt-hg.tar.gz
fix & update
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD43
3 files changed, 38 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da0c2cfcf720..6ec18b9c70fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Fri Apr 10 08:33:29 UTC 2020
pkgbase = soqt-hg
pkgdesc = The glue between Coin & Qt
- pkgver = 1933.e8310fe21c1b
+ pkgver = 2075.2c0e8b0de743
pkgrel = 1
url = https://bitbucket.org/Coin3D/soqt
arch = i686
@@ -8,12 +10,14 @@ pkgbase = soqt-hg
license = GPL
makedepends = doxygen
makedepends = mercurial
- depends = coin
- depends = qt4
+ makedepends = cmake
+ depends = coin-hg
+ depends = qt5-base
provides = soqt
conflicts = soqt
options = !libtool
source = soqt-hg::hg+https://bitbucket.org/Coin3D/soqt
+ source = hg+https://bitbucket.org/Coin3D/cpack.d
source = hg+https://bitbucket.org/Coin3D/generalmsvcgeneration
source = hg+https://bitbucket.org/Coin3D/soanydata
source = hg+https://bitbucket.org/Coin3D/sogui
@@ -21,6 +25,7 @@ pkgbase = soqt-hg
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
+ sha512sums = SKIP
pkgname = soqt-hg
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ab3160f979dd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+/cpack.d/
+/generalmsvcgeneration/
+/soanydata/
+/sogui/
+/soqt-hg/
+/soqt-hg-*.log
+/soqt-hg-*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 9e6acf58ed85..dbef87ff8660 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# Maintainer: Yardena Cohen <yardenack at gmail dot com>
pkgname=soqt-hg
-pkgver=1933.e8310fe21c1b
+pkgver=2075.2c0e8b0de743
pkgrel=1
pkgdesc="The glue between Coin & Qt"
arch=('i686' 'x86_64')
url="https://bitbucket.org/Coin3D/soqt"
license=("GPL")
-depends=('coin' 'qt4')
-makedepends=('doxygen' 'mercurial')
+depends=(coin-hg qt5-base)
+makedepends=(doxygen mercurial cmake)
provides=('soqt')
conflicts=('soqt')
options=('!libtool')
source=("${pkgname}::hg+https://bitbucket.org/Coin3D/soqt"
+ "hg+https://bitbucket.org/Coin3D/cpack.d"
"hg+https://bitbucket.org/Coin3D/generalmsvcgeneration"
"hg+https://bitbucket.org/Coin3D/soanydata"
"hg+https://bitbucket.org/Coin3D/sogui")
-sha512sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
+sha512sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "${srcdir}/${pkgname}"
@@ -24,23 +25,25 @@ pkgver() {
}
build() {
- cd "${srcdir}/${pkgname}"
- ./configure --prefix=/usr \
- --enable-optimization \
- --enable-man \
- --enable-exceptions \
- --disable-debug \
- --disable-maintainer-mode \
- --disable-dependency-tracking \
- --enable-shared \
- --disable-static \
- --with-qt=/usr \
- --enable-threadsafe \
- --enable-html
- make
+ cd "${srcdir}/${pkgname}"
+ cmake \
+ -Bsoqt_build \
+ -G "Unix Makefiles" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DSOQT_BUILD_DOCUMENTATION=OFF \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_PREFIX_PATH=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib
+ cmake \
+ --build soqt_build \
+ --target all \
+ --config Release
}
package() {
- cd "${srcdir}/${pkgname}"
- make DESTDIR=${pkgdir} install
+ cd "${srcdir}/${pkgname}"
+ DESTDIR=${pkgdir} cmake \
+ --build soqt_build \
+ --target install \
+ --config Release
}