summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2023-06-28 23:39:44 +0200
committerNarrat2023-06-28 23:39:44 +0200
commit2ab46032ea1904f422489c8e5e3dd6d33c097cf1 (patch)
tree1fc4b302c034d5d089e3e89caf203f1e78ff31e1
parenta9a6d6209586498ffd580e57b32bfe1dce4354f6 (diff)
downloadaur-2ab46032ea1904f422489c8e5e3dd6d33c097cf1.tar.gz
sos: update to 4.5.5
Patch can only applied partially, therefore not applied until someone fixes this
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD52
2 files changed, 25 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d38ead5c628c..818bd5d8e17e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,23 @@
pkgbase = sos
- pkgdesc = A unified tool for collecting system logs and other debug information
- pkgver = 3.6
- pkgrel = 2
+ pkgdesc = unified tool for collecting system logs and other debug information
+ pkgver = 4.5.5
+ pkgrel = 1
url = https://github.com/sosreport/sos
arch = any
license = GPL2
- checkdepends = python-nose
+ checkdepends = python-pexpect
checkdepends = python-coverage
+ checkdepends = python-pycodestyle
+ checkdepends = python-pyaml
makedepends = python-sphinx
+ makedepends = python-setuptools
depends = python
depends = python-six
depends = python-lxml
backup = etc/sos.conf
- source = https://github.com/sosreport/sos/archive/3.6.tar.gz
+ source = sos-4.5.5.tar.gz::https://github.com/sosreport/sos/archive/4.5.5.tar.gz
source = https://patch-diff.githubusercontent.com/raw/sosreport/sos/pull/1198.patch
- sha256sums = 0e19b80e307140a3af78adb2fe5b821ab3c8fc6fb63d3851c78ef83de2680fd3
- sha256sums = 10478856a9edd42a32d52c1af1b65c86532aed8c0f5b892ce531fb8d3cb41759
+ sha256sums = 8a5ebe38ade95f0cd7d5b2388fedd91239c117709c0f7d533824112cda65b605
+ sha256sums = 2b99f0cb275438c3b1a5f6e260bd057851c14408398e0d25486c642c1c739723
pkgname = sos
-
diff --git a/PKGBUILD b/PKGBUILD
index 47280a11dfad..f900b458ee2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,37 @@
-# Maintainer: chr0mag <phillips.julian AT gmail DOT com>
+# Contributor: chr0mag <phillips.julian AT gmail DOT com>
+
pkgname=sos
-pkgver=3.6
-pkgrel=2
-epoch=
-pkgdesc="A unified tool for collecting system logs and other debug information"
+pkgver=4.5.5
+pkgrel=1
+pkgdesc="unified tool for collecting system logs and other debug information"
arch=('any')
url="https://github.com/sosreport/sos"
license=('GPL2')
-groups=()
depends=('python'
'python-six'
'python-lxml')
-makedepends=('python-sphinx')
-checkdepends=('python-nose'
- 'python-coverage')
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
+makedepends=('python-sphinx' 'python-setuptools')
+checkdepends=(python-pexpect python-coverage python-pycodestyle python-pyaml)
backup=('etc/sos.conf')
-options=()
-install=
-changelog=
_archpullreq="1198.patch"
-source=("https://github.com/sosreport/sos/archive/$pkgver.tar.gz"
- "https://patch-diff.githubusercontent.com/raw/sosreport/sos/pull/$_archpullreq")
-
-noextract=()
-md5sums=()
-sha256sums=('0e19b80e307140a3af78adb2fe5b821ab3c8fc6fb63d3851c78ef83de2680fd3'
- '10478856a9edd42a32d52c1af1b65c86532aed8c0f5b892ce531fb8d3cb41759')
+source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/sosreport/sos/archive/$pkgver.tar.gz"
+ "https://patch-diff.githubusercontent.com/raw/sosreport/sos/pull/$_archpullreq")
+sha256sums=('8a5ebe38ade95f0cd7d5b2388fedd91239c117709c0f7d533824112cda65b605'
+ '2b99f0cb275438c3b1a5f6e260bd057851c14408398e0d25486c642c1c739723')
-validpgpkeys=()
prepare() {
cd "$pkgname-$pkgver"
- patch --strip=1 < ../$_archpullreq
+ # Currently doesn't work with 4.x.x
+ #patch --strip=1 < ../$_archpullreq
}
build() {
cd "$pkgname-$pkgver"
- make build
-}
-
-check() {
- cd "$pkgname-$pkgver"
- make test
+ python setup.py build
}
package() {
cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir" install
- #put binary in /usr/bin instead of /usr/sbin
- mkdir ${pkgdir}/usr/bin
- mv ${pkgdir}/usr/sbin/sosreport ${pkgdir}/usr/bin
- rmdir ${pkgdir}/usr/sbin
- #rmdir ${pkgdir}/usr/share/doc/sos ${pkgdir}/usr/share/sos/extras
+ python setup.py install --root="$pkgdir" --optimize=1
}