summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuan Garza2021-07-14 21:40:07 -0500
committerJuan Garza2021-07-14 21:40:07 -0500
commit2b77e474b220d3266ad1d573ad044b575641602b (patch)
tree72da89ed2a9aa8b3004a9c4476a9989c58ef5c89
parentf9eeb6e2e12ad435defbb0cd88da6a0090935cf3 (diff)
downloadaur-2b77e474b220d3266ad1d573ad044b575641602b.tar.gz
v1.3.3
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD95
2 files changed, 56 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cca8cee4e02b..fab11263fa4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sotw
pkgdesc = Shadow Of The Wyrm is a single player, traditional roguelike by Julian Day.
- pkgver = 1.3.2
+ pkgver = 1.3.3
pkgrel = 1
url = http://www.shadowofthewyrm.org/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index df7baae44e01..77ca0240a484 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer: Larzid <juanitocampamocha@gmail.com>
pkgname=sotw
-pkgver=1.3.2
+pkgver=1.3.3
pkgrel=1
epoch=
pkgdesc="Shadow Of The Wyrm is a single player, traditional roguelike by Julian Day."
@@ -23,46 +23,61 @@ md5sums=('SKIP' 'SKIP')
validpgpkeys=('SKIP')
build() {
- cd shadow-of-the-wyrm
- git checkout master
- premake5 --lua_include=/usr/include/lua5.1 --lua_link=lua5.1 gmake
- make config=release
- #make config=debug
+ cd shadow-of-the-wyrm
+ # git checkout develop
+ premake5 --lua_include=/usr/include/lua5.1 --lua_link=lua5.1 gmake
+ make config=release
}
package() {
- echo "#!/bin/sh" > ${srcdir}/shadow-of-the-wyrm/sotw.sh
- echo "cd /usr/share/shadow-of-the-wyrm" >> ${srcdir}/shadow-of-the-wyrm/sotw.sh
- echo "./ShadowOfTheWyrm" >> ${srcdir}/shadow-of-the-wyrm/sotw.sh
- echo "[Desktop Entry]
- Version=1.3.0
- Name=Shadow Of The Wyrm
- GenericName=SOTW
- Type=Application
- Comment=A single player, traditional roguelike by Julian Day.
- Icon=sotw
- Exec=sotw
- Terminal=false
- SartupNotify=false
- Keywords=game;roguelike;
- Categories=Game;" > ${srcdir}/sotw.desktop
- chmod +x ${srcdir}/shadow-of-the-wyrm/sotw.sh
- install -D -m644 ${srcdir}/shadow-of-the-wyrm/LICENSE "${pkgdir}/usr/share/licenses/shadow-of-the-wyrm/LICENSE"
- install -d -m777 ${srcdir}/shadow-of-the-wyrm "${pkgdir}/usr/share/shadow-of-the-wyrm"
- install -D ${srcdir}/shadow-of-the-wyrm/bin/Release/ShadowOfTheWyrm "${pkgdir}/usr/share/shadow-of-the-wyrm/ShadowOfTheWyrm"
- install -D ${srcdir}/shadow-of-the-wyrm/shadowofthewyrmtext_blank.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/shadowofthewyrmtext_blank.ini"
- install -D ${srcdir}/shadow-of-the-wyrm/shadowofthewyrmtext_en.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/shadowofthewyrmtext_en.ini"
- install -D ${srcdir}/shadow-of-the-wyrm/swyrm.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/swyrm.ini"
- install -D ${srcdir}/shadow-of-the-wyrm/version_info.txt "${pkgdir}/usr/share/shadow-of-the-wyrm/version_info.txt"
- cp -R ${srcdir}/shadow-of-the-wyrm/assets ${pkgdir}/usr/share/shadow-of-the-wyrm/assets
- cp -R ${srcdir}/shadow-of-the-wyrm/data ${pkgdir}/usr/share/shadow-of-the-wyrm/data
- cp -R ${srcdir}/shadow-of-the-wyrm/docs ${pkgdir}/usr/share/shadow-of-the-wyrm/docs
- cp -R ${srcdir}/shadow-of-the-wyrm/licenses ${pkgdir}/usr/share/shadow-of-the-wyrm/licenses
- cp -R ${srcdir}/shadow-of-the-wyrm/scripts ${pkgdir}/usr/share/shadow-of-the-wyrm/scripts
- cp -R ${srcdir}/shadow-of-the-wyrm/texts ${pkgdir}/usr/share/shadow-of-the-wyrm/texts
- mkdir ${pkgdir}/usr/share/icons/
- mkdir ${pkgdir}/usr/share/applications/
- cp -R ${srcdir}/z9QmK0X.png ${pkgdir}/usr/share/icons/sotw.png
- cp -R ${srcdir}/sotw.desktop ${pkgdir}/usr/share/applications/sotw.desktop
- install -D ${srcdir}/shadow-of-the-wyrm/sotw.sh ${pkgdir}/usr/bin/sotw
+# Create launch script.
+ echo "#!/bin/sh" > ${srcdir}/shadow-of-the-wyrm/sotw.sh
+ echo "cd /usr/share/shadow-of-the-wyrm" >> ${srcdir}/shadow-of-the-wyrm/sotw.sh
+ echo "./ShadowOfTheWyrm" >> ${srcdir}/shadow-of-the-wyrm/sotw.sh
+ chmod +x ${srcdir}/shadow-of-the-wyrm/sotw.sh
+
+# Create the .desktop entry.
+ echo "[Desktop Entry]
+ Version=$pkgver
+ Name=Shadow Of The Wyrm
+ GenericName=SOTW
+ Type=Application
+ Comment=A single player, traditional roguelike by Julian Day.
+ Icon=sotw
+ Exec=sotw
+ Terminal=false
+ SartupNotify=false
+ Keywords=game;roguelike;
+ Categories=Game;" > ${srcdir}/sotw.desktop
+
+# Tweak game settings.
+ # Setup log directory.
+ sed -i -e 's|'"log_dir="'|'"log_dir=/var/sotw"'|g' ${srcdir}/shadow-of-the-wyrm/swyrm.ini
+ mkdir ${pkgdir}/var
+ mkdir ${pkgdir}/var/sotw
+ chmod 777 ${pkgdir}/var/sotw
+ # Set system dump directory.
+ sed -i -e 's|'"syschardump_dir="'|'"syschardump_dir=/var/sotw"'|g' ${srcdir}/shadow-of-the-wyrm/swyrm.ini
+ # Set disallow score for narrative mode and console commands.
+ sed -i -e 's|'"_disallow_score_on_exploration=0"'|'"_disallow_score_on_exploration=1"'|g' ${srcdir}/shadow-of-the-wyrm/swyrm.ini
+
+# Do the actual packaging.
+ install -D -m644 ${srcdir}/shadow-of-the-wyrm/LICENSE "${pkgdir}/usr/share/licenses/shadow-of-the-wyrm/LICENSE"
+ install -d -m777 ${srcdir}/shadow-of-the-wyrm "${pkgdir}/usr/share/shadow-of-the-wyrm"
+ install -D ${srcdir}/shadow-of-the-wyrm/bin/Release/ShadowOfTheWyrm "${pkgdir}/usr/share/shadow-of-the-wyrm/ShadowOfTheWyrm"
+ install -D ${srcdir}/shadow-of-the-wyrm/shadowofthewyrmtext_blank.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/shadowofthewyrmtext_blank.ini"
+ install -D ${srcdir}/shadow-of-the-wyrm/shadowofthewyrmtext_en.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/shadowofthewyrmtext_en.ini"
+ install -D ${srcdir}/shadow-of-the-wyrm/swyrm.ini "${pkgdir}/usr/share/shadow-of-the-wyrm/swyrm.ini"
+ install -D ${srcdir}/shadow-of-the-wyrm/version_info.txt "${pkgdir}/usr/share/shadow-of-the-wyrm/version_info.txt"
+ cp -R ${srcdir}/shadow-of-the-wyrm/assets ${pkgdir}/usr/share/shadow-of-the-wyrm/assets
+ cp -R ${srcdir}/shadow-of-the-wyrm/data ${pkgdir}/usr/share/shadow-of-the-wyrm/data
+ cp -R ${srcdir}/shadow-of-the-wyrm/docs ${pkgdir}/usr/share/shadow-of-the-wyrm/docs
+ cp -R ${srcdir}/shadow-of-the-wyrm/licenses ${pkgdir}/usr/share/shadow-of-the-wyrm/licenses
+ cp -R ${srcdir}/shadow-of-the-wyrm/scripts ${pkgdir}/usr/share/shadow-of-the-wyrm/scripts
+ cp -R ${srcdir}/shadow-of-the-wyrm/texts ${pkgdir}/usr/share/shadow-of-the-wyrm/texts
+ mkdir ${pkgdir}/usr/share/icons/
+ mkdir ${pkgdir}/usr/share/applications/
+ cp -R ${srcdir}/z9QmK0X.png ${pkgdir}/usr/share/icons/sotw.png
+ cp -R ${srcdir}/sotw.desktop ${pkgdir}/usr/share/applications/sotw.desktop
+ install -D ${srcdir}/shadow-of-the-wyrm/sotw.sh ${pkgdir}/usr/bin/sotw
}