summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrystian Chachuła2019-02-17 18:06:30 +0100
committerKrystian Chachuła2019-02-17 18:06:30 +0100
commit2b66143340fd3533ce802d60e773669d31342218 (patch)
tree7d4eb4083780e06bfea09450368c1c54e327e247
downloadaur-2b66143340fd3533ce802d60e773669d31342218.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e57f827deb3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = soundfont-fatboy
+ pkgdesc = A free GM/GS SoundFont for classic video game MIDI, emulation, and general usage.
+ pkgver = 0.785
+ pkgrel = 1
+ url = https://fatboy.site/
+ arch = any
+ license = unknown
+ source = https://dl.fatboy.site/FatBoy-latest.7z
+ md5sums = SKIP
+
+pkgname = soundfont-fatboy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b802e0abb552
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Krystian Chachuła <krystiancha@gmail.com>
+pkgname=soundfont-fatboy
+pkgver=0.785
+pkgrel=1
+pkgdesc="A free GM/GS SoundFont for classic video game MIDI, emulation, and general usage."
+arch=('any')
+url="https://fatboy.site/"
+license=('unknown')
+source=("https://dl.fatboy.site/FatBoy-latest.7z")
+md5sums=("SKIP")
+
+pkgver() {
+ echo *sf2 | sed -e 's/FatBoy-v\(.*\).sf2/\1/'
+}
+
+package() {
+ install -D "FatBoy-v$pkgver.sf2" "$pkgdir/usr/share/soundfonts/FatBoy.sf2"
+}