summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhantasm2023-01-21 00:06:23 +0100
committerPhantasm2023-01-21 00:06:23 +0100
commitd8cef52afde24e46386694231a160da97fd1f241 (patch)
tree7a528ed65c84f150a756fb14a4bfd68de7e1ecc8
downloadaur-d8cef52afde24e46386694231a160da97fd1f241.tar.gz
Initial commit
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD53
2 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69427609f1da
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = soundkonverter-dark-theme-git
+ pkgdesc = Front-end to various audio converters (Git - with custom colors for dark themes)
+ pkgver = 3.0.1.r28.ge2927e9
+ pkgrel = 1
+ url = https://www.linux-apps.com/content/show.php?content=29024
+ arch = x86_64
+ license = GPL
+ makedepends = extra-cmake-modules
+ makedepends = kdesignerplugin
+ makedepends = kdoctools
+ makedepends = kinit
+ makedepends = git
+ depends = hicolor-icon-theme
+ depends = kdelibs4support
+ depends = libkcddb
+ depends = taglib
+ depends = phonon-qt5
+ optdepends = faac: faac backend
+ optdepends = faad2: faad backend
+ optdepends = ffmpeg: ffmpeg backend
+ optdepends = flac: flac backend
+ optdepends = fluidsynth: flouidsynth backend
+ optdepends = lame: lame backend
+ optdepends = mac: mac backend
+ optdepends = mplayer: mplayer backend
+ optdepends = opus-tools: opus backend
+ optdepends = speex: speexenc, speexdec backends
+ optdepends = timidity++: midi backend
+ optdepends = twolame: twolame backend
+ optdepends = vorbisgain: vorbisgain backend
+ optdepends = vorbis-tools: vorbis tools backend
+ optdepends = wavpack: wavpack backend
+ optdepends = sox: sox plugin (change sample rate, various effects)
+ provides = soundkonverter
+ conflicts = soundkonverter
+ source = git+https://github.com/nphantasm/soundkonverter.git
+ sha256sums = SKIP
+
+pkgname = soundkonverter-dark-theme-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7dcea5277708
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Phantasm <phantasm@centrum.cz>
+# Based on the official Arch Linux PKGBUILD
+
+pkgname=soundkonverter-dark-theme-git
+_name=soundkonverter
+pkgver=3.0.1.r28.ge2927e9
+pkgrel=1
+pkgdesc="Front-end to various audio converters (Git - with custom colors for dark themes)"
+arch=(x86_64)
+url="https://www.linux-apps.com/content/show.php?content=29024"
+license=(GPL)
+depends=(hicolor-icon-theme kdelibs4support libkcddb taglib phonon-qt5)
+makedepends=(extra-cmake-modules kdesignerplugin kdoctools kinit git)
+optdepends=('faac: faac backend'
+ 'faad2: faad backend'
+ 'ffmpeg: ffmpeg backend'
+ 'flac: flac backend'
+ 'fluidsynth: flouidsynth backend'
+ 'lame: lame backend'
+ 'mac: mac backend'
+ 'mplayer: mplayer backend'
+ 'opus-tools: opus backend'
+ 'speex: speexenc, speexdec backends'
+ 'timidity++: midi backend'
+ 'twolame: twolame backend'
+ 'vorbisgain: vorbisgain backend'
+ 'vorbis-tools: vorbis tools backend'
+ 'wavpack: wavpack backend'
+ 'sox: sox plugin (change sample rate, various effects)')
+source=("git+https://github.com/nphantasm/soundkonverter.git")
+provides=(soundkonverter)
+conflicts=(soundkonverter)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_name"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../"$_name"/src
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}