summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYoshi28892016-07-26 14:26:22 +0200
committerYoshi28892016-07-26 14:26:22 +0200
commit649aec14cb7366de296ce2054398001fdbbe6539 (patch)
tree89cb60a9b997b066f838d5dbd24a19da0786c9a5
downloadaur-649aec14cb7366de296ce2054398001fdbbe6539.tar.gz
Initial commit
Signed-off-by: Yoshi2889 <rick.2889@gmail.com>
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD50
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a38d512ca7f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Tue Jul 26 12:25:33 UTC 2016
+pkgbase = soundnode-git
+ pkgdesc = Soundcloud client for the desktop
+ pkgver = 0.6.5
+ pkgrel = 1
+ url = http://www.soundnodeapp.com/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ makedepends = npm
+ makedepends = wine
+ depends = gconf
+ depends = gtk2
+ depends = libxtst
+ depends = nss
+ depends = alsa-lib
+ depends = libnotify
+ depends = fontconfig
+ options = !strip
+ source = git+https://github.com/Soundnode/soundnode-app.git
+ sha256sums = SKIP
+
+pkgname = soundnode-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c020479a2d4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Rick Kerkhof <rick.2889@gmail.com>
+pkgname=soundnode-git
+pkgver=0.6.5
+pkgrel=1
+pkgdesc="Soundcloud client for the desktop"
+arch=('x86_64' 'i686')
+url="http://www.soundnodeapp.com/"
+license=('GPL3')
+
+# Required, otherwise it won't run.
+options=('!strip')
+
+depends=('gconf' 'gtk2' 'libxtst' 'nss' 'alsa-lib' 'libnotify' 'fontconfig')
+
+# This thing requires wine to build, and just to create an icon for the win32 instance.
+# Fails if it doesn't exist, so we better include it.
+makedepends=('git' 'npm' 'wine')
+
+source=("git+https://github.com/Soundnode/soundnode-app.git")
+sha256sums=("SKIP")
+
+
+build() {
+ cd soundnode-app
+
+ make build
+}
+
+package() {
+ install -dm755 "$pkgdir"/usr/bin
+ install -dm755 "$pkgdir"/opt/
+ install -dm755 "$pkgdir"/usr/share/applications/
+ install -Dm644 "$srcdir"/soundnode-app/fpm/soundnode.desktop "$pkgdir"/usr/share/applications/
+
+ if [ -d "$srcdir"/build ]; then
+ rm -r "$srcdir"/build
+ fi
+
+ mkdir "$srcdir"/build
+ if [ $CARCH = "x86_64" ]; then
+ cp -Lr "$srcdir"/soundnode-app/dist/Soundnode/linux64/* "$srcdir"/build
+ else
+ cp -Lr "$srcdir"/soundnode-app/dist/Soundnode/linux32/* "$srcdir"/build
+ fi
+
+ # We're creating a broken link here. It'll be fixed when all files are in place :)
+ ln -s /opt/"$pkgname"/Soundnode "$pkgdir"/usr/bin/soundnode
+
+ cp -Lr "$srcdir"/build "$pkgdir"/opt/"$pkgname"
+}