summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYoshi28892017-01-20 10:29:23 +0100
committerYoshi28892017-01-20 10:29:23 +0100
commit9f667ca11676e0aa27fce651e3e72f5226d0b296 (patch)
treec8f1d407fe5065ebe7bef507de4475e510a1bb41
parenta5d386c22c2775aa1b0ada3f795d2d7a6e3c170b (diff)
downloadaur-9f667ca11676e0aa27fce651e3e72f5226d0b296.tar.gz
Fix git package; bye Wine
Signed-off-by: Yoshi2889 <rick.2889@gmail.com>
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD64
-rw-r--r--soundnode-git.desktop9
3 files changed, 43 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d92621eeb24d..7eb4aff1c631 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
# Generated by mksrcinfo v8
-# Tue Aug 23 18:19:51 UTC 2016
+# Fri Jan 20 09:28:21 UTC 2017
pkgbase = soundnode-git
pkgdesc = Soundcloud client for the desktop
- pkgver = r774.3175946
- pkgrel = 5
+ pkgver = r832.982e279
+ pkgrel = 1
url = http://www.soundnodeapp.com/
arch = x86_64
arch = i686
license = GPL3
makedepends = git
makedepends = npm
- makedepends = wine
- makedepends = wine-mono
- makedepends = wine_gecko
- makedepends = nw-gyp
depends = gconf
depends = gtk2
depends = libxtst
@@ -26,7 +22,9 @@ pkgbase = soundnode-git
conflicts = soundnode-app-bin
options = !strip
source = git+https://github.com/Soundnode/soundnode-app.git
+ source = soundnode-git.desktop
sha256sums = SKIP
+ sha256sums = 4613630387d6a2073bff66f8fe3d0d352d353ad50811e19ec2470fe09f88985a
pkgname = soundnode-git
diff --git a/PKGBUILD b/PKGBUILD
index 392e29738e79..dda5c6b982d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Rick Kerkhof <rick.2889@gmail.com>
pkgname=soundnode-git
-pkgver=r774.3175946
-pkgrel=5
+pkgver=r832.982e279
+pkgrel=1
pkgdesc="Soundcloud client for the desktop"
arch=('x86_64' 'i686')
url="http://www.soundnodeapp.com/"
@@ -13,46 +13,40 @@ provides=('soundnode')
options=('!strip')
depends=('gconf' 'gtk2' 'libxtst' 'nss' 'alsa-lib' 'libnotify' 'fontconfig')
+makedepends=('git' 'npm')
-# This thing requires wine to build, and just to create an icon for the win32 instance.
-# Fails if it doesn't exist, so we better include it.
-makedepends=('git' 'npm' 'wine' 'wine-mono' 'wine_gecko' 'nw-gyp')
-
-source=("git+https://github.com/Soundnode/soundnode-app.git")
-sha256sums=("SKIP")
+source=("git+https://github.com/Soundnode/soundnode-app.git"
+ "$pkgname.desktop")
+sha256sums=('SKIP'
+ '4613630387d6a2073bff66f8fe3d0d352d353ad50811e19ec2470fe09f88985a')
pkgver() {
- cd soundnode-app
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd soundnode-app
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd soundnode-app
- sed -i -e "s/\/usr\/share\/soundnode\/Soundnode/\/opt\/soundnode-git\/Soundnode/g" fpm/soundnode.desktop
-
- make build
+ cd soundnode-app
+ npm install
+ npm run clean
+ npm run webpack:prod
+ npm run sass:prod
+ npm run package:linux
}
package() {
- install -dm755 "$pkgdir"/usr/bin
- install -dm755 "$pkgdir"/opt/
- install -dm755 "$pkgdir"/usr/share/applications/
-
- install -Dm644 "$srcdir"/soundnode-app/fpm/soundnode.desktop "$pkgdir"/usr/share/applications/
-
- if [ -d "$srcdir"/build ]; then
- rm -r "$srcdir"/build
- fi
-
- mkdir "$srcdir"/build
- if [ $CARCH = "x86_64" ]; then
- cp -Lr "$srcdir"/soundnode-app/dist/Soundnode/linux64/* "$srcdir"/build
- else
- cp -Lr "$srcdir"/soundnode-app/dist/Soundnode/linux32/* "$srcdir"/build
- fi
-
- # We're creating a broken link here. It'll be fixed when all files are in place :)
- ln -s /opt/"$pkgname"/Soundnode "$pkgdir"/usr/bin/soundnode
-
- cp -Lr "$srcdir"/build "$pkgdir"/opt/"$pkgname"
+ install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+
+ install -dm755 $pkgdir/opt/$pkgname
+
+ if [ $CARCH = "x86_64" ]; then
+ cp -a --no-preserve=ownership -r $srcdir/soundnode-app/dist/Soundnode/Soundnode-linux-x64/* $pkgdir/opt/$pkgname
+ install -Dm644 $srcdir/soundnode-app/dist/Soundnode/Soundnode-linux-x64/Soundnode $pkgdir/usr/bin/soundnode
+ else
+ cp -a --no-preserve=ownership -r $srcdir/soundnode-app/dist/Soundnode/Soundnode-linux-x32/* $pkgdir/opt/$pkgname
+ install -Dm644 $srcdir/soundnode-app/dist/Soundnode/Soundnode-linux-x32/Soundnode $pkgdir/usr/bin/soundnode
+ fi
+
+ # Install the icon
+ install -Dm644 $srcdir/soundnode-app/app/soundnode.png $pkgdir/opt/$pkgname/soundnode.png
}
diff --git a/soundnode-git.desktop b/soundnode-git.desktop
new file mode 100644
index 000000000000..b0528f12e6e6
--- /dev/null
+++ b/soundnode-git.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Soundnode
+GenericName=Soundcloud client
+Comment=Soundnode App is an Open-Source project to support Soundcloud for desktop Mac, Windows, and Linux.
+Exec=/opt/soundnode-git/Soundnode
+Icon=/opt/soundnode-git/soundnode.png
+Terminal=false
+Categories=AudioVideo;Audio;
+Type=Application