summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2017-11-18 18:32:31 -0500
committerAndrew O'Neill2017-11-18 18:32:31 -0500
commit5bad69b463eaae35b08082fe6d18565f91282d95 (patch)
treeb7e25e4abff8593a106da69bf2d797479b929a0d
parent8cae94b8d9d930d63a4bd5a9dc09f6c050900324 (diff)
downloadaur-5bad69b463eaae35b08082fe6d18565f91282d95.tar.gz
Version bump
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD29
2 files changed, 22 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74f773f7bfb6..aaadda6df98d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = soundpipe
- pkgdesc = A lightweight music DSP library.
- pkgver = 1.5.0
+ pkgdesc = A lightweight music DSP library
+ pkgver = 1.6.0
pkgrel = 1
url = http://paulbatchelor.github.io/proj/soundpipe.html
- arch = any
+ arch = x86_64
license = MIT
makedepends = libsndfile
- source = https://github.com/PaulBatchelor/soundpipe/archive/v1.5.0.tar.gz
- md5sums = e9bd3c1f2b47f05a76cc89e47f2f68b1
+ source = https://github.com/PaulBatchelor/soundpipe/archive/v1.6.0.tar.gz
+ sha256sums = 107a890a87005a8bb1859e91a2f9eeb1b14ab489f86f8b2b42002db81bde04b2
pkgname = soundpipe
diff --git a/PKGBUILD b/PKGBUILD
index f315d0c0896f..98bfcf2d39f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,29 @@
-# Maintainer: Teteros <teteros -at- openmailbox -dot- org>
+# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
+# Contributor: Teteros <teteros -at- openmailbox -dot- org>
_pkgname=Soundpipe
pkgname=soundpipe
-pkgver=1.5.0
+pkgver=1.6.0
pkgrel=1
-pkgdesc="A lightweight music DSP library."
-arch=(any)
+pkgdesc="A lightweight music DSP library"
+arch=('x86_64')
url="http://paulbatchelor.github.io/proj/soundpipe.html"
-license=(MIT)
-makedepends=(libsndfile)
-source=("https://github.com/PaulBatchelor/${pkgname}/archive/v${pkgver}.tar.gz")
-md5sums=('e9bd3c1f2b47f05a76cc89e47f2f68b1')
+license=('MIT')
+makedepends=('libsndfile')
+source=(https://github.com/PaulBatchelor/$pkgname/archive/v$pkgver.tar.gz)
+sha256sums=('107a890a87005a8bb1859e91a2f9eeb1b14ab489f86f8b2b42002db81bde04b2')
build() {
- cd "${_pkgname}-${pkgver}"
+ cd $_pkgname-$pkgver
+
make
}
package() {
- cd "${_pkgname}-${pkgver}"
- PREFIX="${pkgdir}/usr" make install -e
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd $_pkgname-$pkgver
+
+ PREFIX=$pkgdir/usr make install -e
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ mkdir -p $pkgdir/usr/share/doc/$pkgname
+ cp -rp examples $pkgdir/usr/share/doc/$pkgname
}