summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTeteros2017-04-07 03:36:23 +0000
committerTeteros2017-04-07 03:36:23 +0000
commit8cae94b8d9d930d63a4bd5a9dc09f6c050900324 (patch)
treed4acb1d8e7c9c903d97aa628507a9a96e8d4b5eb
downloadaur-8cae94b8d9d930d63a4bd5a9dc09f6c050900324.tar.gz
init repo
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74f773f7bfb6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = soundpipe
+ pkgdesc = A lightweight music DSP library.
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = http://paulbatchelor.github.io/proj/soundpipe.html
+ arch = any
+ license = MIT
+ makedepends = libsndfile
+ source = https://github.com/PaulBatchelor/soundpipe/archive/v1.5.0.tar.gz
+ md5sums = e9bd3c1f2b47f05a76cc89e47f2f68b1
+
+pkgname = soundpipe
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f315d0c0896f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Teteros <teteros -at- openmailbox -dot- org>
+
+_pkgname=Soundpipe
+pkgname=soundpipe
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="A lightweight music DSP library."
+arch=(any)
+url="http://paulbatchelor.github.io/proj/soundpipe.html"
+license=(MIT)
+makedepends=(libsndfile)
+source=("https://github.com/PaulBatchelor/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('e9bd3c1f2b47f05a76cc89e47f2f68b1')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ PREFIX="${pkgdir}/usr" make install -e
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}