summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStorm Dragon2015-06-08 16:00:52 -0400
committerStorm Dragon2015-06-08 16:00:52 -0400
commit216786c1ee27fe2a35c1299521ecde6d4cd35717 (patch)
tree77991027a826a24692b146324eebbcc670de8c33
downloadaur-216786c1ee27fe2a35c1299521ecde6d4cd35717.tar.gz
Initial import.
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD40
-rw-r--r--soundrts.desktop12
-rw-r--r--soundrts.sh5
4 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..017a43d88790
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = soundrts-git
+ pkgdesc = A real-time strategy audio game
+ pkgver = 1.2.a8.r6.g395d894
+ pkgrel = 1
+ url = https://github.com/soundmud/soundrts
+ arch = any
+ license = BSD
+ license = Unknown
+ makedepends = git
+ depends = python2
+ depends = python2-pygame
+ optdepends = espeak: TTS support
+ optdepends = speech-dispatcher: TTS support
+ optdepends = python2-speechd: For speech-dispatcher to work with SoundRTS.
+ provides = soundrts
+ conflicts = soundrts
+ source = soundrts::git+git://github.com/soundmud/soundrts.git
+ source = soundrts.desktop
+ source = soundrts.sh
+ md5sums = SKIP
+ md5sums = d06721831d47dd0dc5b1c5d19ba55f59
+ md5sums = a2ef4d68f7a926f661c30f487e22e0fa
+
+pkgname = soundrts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c79a4e6839a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
+# Contributor: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
+_pkgname=soundrts
+pkgname=$_pkgname-git
+pkgver=1.2.a8.r6.g395d894
+pkgrel=1
+pkgdesc="A real-time strategy audio game"
+arch=('any')
+url="https://github.com/soundmud/soundrts"
+license=('BSD' 'Unknown')
+depends=('python2' 'python2-pygame')
+makedepends=('git')
+optdepends=('espeak: TTS support'
+ 'speech-dispatcher: TTS support'
+ 'python2-speechd: For speech-dispatcher to work with SoundRTS.')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+git://github.com/soundmud/soundrts.git"
+ "$_pkgname.desktop"
+ "$_pkgname.sh")
+md5sums=('SKIP'
+ 'd06721831d47dd0dc5b1c5d19ba55f59'
+ 'a2ef4d68f7a926f661c30f487e22e0fa')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$_pkgname"
+ install -d "$pkgdir/opt/soundrts"
+ cp -a * "$pkgdir/opt/soundrts" # not very nice, this installs a lot of unnecessary files
+
+ install -Dm755 "$srcdir/$_pkgname.sh" "$pkgdir/usr/bin/$_pkgname"
+
+ install -Dm644 "$srcdir/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/soundrts.desktop b/soundrts.desktop
new file mode 100644
index 000000000000..86aaf4682df2
--- /dev/null
+++ b/soundrts.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Encoding=UTF-8
+Name=SoundRTS
+GenericName=A real-time strategy audio game
+Comment=A real-time strategy audio game
+Path=/opt/soundrts
+Exec=python2 soundrts.py
+Terminal=false
+StartupNotify=true
+Categories=Application;Game;ArcadeGame
diff --git a/soundrts.sh b/soundrts.sh
new file mode 100644
index 000000000000..5ea06767e2d8
--- /dev/null
+++ b/soundrts.sh
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+cd /opt/soundrts
+python2 soundrts.py
+exit 0