summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-28 11:10:02 +0800
committerzxp198210052024-02-28 11:10:02 +0800
commitaa8c0a14ba2938fdf1213169c78cd296e83c4bda (patch)
treee87b24e96a94d4738d95b235b03b3e919be64699
parent81fcf9dba15e87e080e3972f0cf40176be2e9768 (diff)
downloadaur-aa8c0a14ba2938fdf1213169c78cd296e83c4bda.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
-rw-r--r--soundsync.sh9
3 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ad1ca85c53b..384e43744aee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = soundsync-bin
pkgdesc = Virtual cables between any audio source and any speaker in your home
pkgver = 0.4.16
- pkgrel = 8
+ pkgrel = 9
url = https://soundsync.app/
arch = x86_64
- license = custom:BSL1.1
+ license = BUSL1.1
depends = electron15
depends = libpulse
- depends = python
+ depends = python>3
+ depends = nodejs
provides = soundsync=0.4.16
conflicts = soundsync
source = soundsync-0.4.16.pacman::https://github.com/geekuillaume/soundsync/releases/download/v0.4.16/soundsync-x64-0.4.16.pacman
@@ -17,6 +18,6 @@ pkgbase = soundsync-bin
sha256sums = 12bd6190537d80a29fa89fa2fa37da310593d5e6c54a7fe9f16c5f1509d4b94c
sha256sums = 0c659fd7972a1a233b161380cfb177149d6d75b3c4f97c8cf8bbd8eb91b026d0
sha256sums = b0b07f20aa91c04c6aa05590ebd4d4697b2939283bcb122810759a2ed961a005
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = soundsync-bin
diff --git a/PKGBUILD b/PKGBUILD
index af5a10e7dadd..e44919e08a7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,19 @@ pkgname=soundsync-bin
_pkgname=Soundsync
pkgver=0.4.16
_electronversion=15
-pkgrel=8
+pkgrel=9
pkgdesc="Virtual cables between any audio source and any speaker in your home"
arch=('x86_64')
url="https://soundsync.app/"
_ghurl="https://github.com/geekuillaume/soundsync"
-license=('custom:BSL1.1')
+license=('BUSL1.1')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
'libpulse'
- 'python'
+ 'python>3'
+ 'nodejs'
)
source=(
"${pkgname%-bin}-${pkgver}.pacman::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-x64-${pkgver}.pacman"
@@ -25,11 +26,11 @@ source=(
sha256sums=('12bd6190537d80a29fa89fa2fa37da310593d5e6c54a7fe9f16c5f1509d4b94c'
'0c659fd7972a1a233b161380cfb177149d6d75b3c4f97c8cf8bbd8eb91b026d0'
'b0b07f20aa91c04c6aa05590ebd4d4697b2939283bcb122810759a2ed961a005'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
diff --git a/soundsync.sh b/soundsync.sh
index aacd8f895847..f9ced1432cfc 100644
--- a/soundsync.sh
+++ b/soundsync.sh
@@ -1,15 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file