summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-22 19:46:54 +0800
committerChocobo12017-08-22 19:59:29 +0800
commit8f6f53379ab9d71387ca1a64ed71d85ccf61d691 (patch)
treec5523ffa1eba8306868f24eeb5138c77b8860c1e
downloadaur-8f6f53379ab9d71387ca1a64ed71d85ccf61d691.tar.gz
newpkg: soundtouch-svn r255-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..284239184660
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = soundtouch-svn
+ pkgdesc = Audio processing library for changing the tempo, pitch and playback rates of audio streams or audio files
+ pkgver = r255
+ pkgrel = 1
+ url = https://www.surina.net/soundtouch/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = glibc
+ provides = soundtouch
+ conflicts = soundtouch
+ source = svn+https://svn.code.sf.net/p/soundtouch/code/trunk
+ sha256sums = SKIP
+
+pkgname = soundtouch-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dea96f31ad83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=soundtouch-svn
+pkgver=r255
+pkgrel=1
+pkgdesc="Audio processing library for changing the tempo, pitch and playback rates of audio streams or audio files"
+arch=('i686' 'x86_64')
+url="https://www.surina.net/soundtouch/"
+license=('LGPL')
+depends=('glibc')
+makedepends=('git')
+provides=('soundtouch')
+conflicts=('soundtouch')
+source=("svn+https://svn.code.sf.net/p/soundtouch/code/trunk")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "trunk"
+
+ _ver="$(svnversion)"
+ printf "r%s" "${_ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "trunk"
+
+ ./bootstrap
+ ./configure --prefix="/usr"
+ make
+}
+
+package() {
+ cd "trunk"
+
+ make DESTDIR="$pkgdir" install
+
+ rm "$pkgdir/usr/share/doc/soundtouch/COPYING.TXT"
+}