summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCurve2023-05-19 21:01:49 +0200
committerCurve2023-05-19 21:01:49 +0200
commit1989ce61cf9353f897273b2707188f418dc914a1 (patch)
treeb85b515775d29ce65f1bcd3bae21054bc2d1cdcd
parent90f19e77f59934a0c890b1ec2f92ee608bf213a3 (diff)
downloadaur-1989ce61cf9353f897273b2707188f418dc914a1.tar.gz
fix compilation
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5abc4c62db96..9dc5b0ef9a7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = soundux
pkgdesc = A cross-platform soundboard - stable version
pkgver = 0.2.7
- pkgrel = 2
+ pkgrel = 3
url = https://soundux.rocks
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index fde4ec727459..c432ae1d4dd9 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Nico <d3sox at protonmail dot com>
pkgname=soundux
pkgver=0.2.7
-pkgrel=2
+pkgrel=3
pkgdesc="A cross-platform soundboard - stable version"
arch=('any')
url="https://soundux.rocks"
@@ -13,13 +13,16 @@ source=("https://github.com/Soundux/Soundux/releases/download/$pkgver/soundux-$p
sha256sums=('017003fc96f49df30575975f3904c0d8a500e325a9d2bca8c3dc69fed0cab0a7')
prepare() {
- sed -i /-Werror/d "$srcdir/Soundux/CMakeLists.txt"
+ echo "add_definitions(-Wno-deprecated)" >> "$srcdir/Soundux/CMakeLists.txt"
+ sed -i "/pthread.h/c\#include <pthread.h>\n#include <cstdint>" "$srcdir/Soundux/lib/guardpp/guard/include/core/linux/guard.hpp"
+ sed -i "/target_compile_options/c\add_definitions(-w)" "$srcdir/Soundux/src/ui/impl/webview/lib/webviewpp/CMakeLists.txt"
}
build() {
cd "${srcdir}/Soundux"
mkdir -p build
cd build
+
cmake -GNinja -DCMAKE_BUILD_TYPE=Release ..
ninja
}