summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3SOX2022-04-03 00:22:44 +0200
committerD3SOX2022-04-03 00:22:44 +0200
commit74f546d6da50a6b2c687b56b21d0c6435e7064ce (patch)
tree31083eb1943a47c076c823acf5679e7b124efe64
parentd26aa8d7577ec837a3cf30301c0af74dab9e9cf1 (diff)
downloadaur-74f546d6da50a6b2c687b56b21d0c6435e7064ce.tar.gz
add missing build dependency and warning message
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD5
-rw-r--r--soundux.install10
3 files changed, 16 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a1cf5de58ce..575009f2300d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,12 @@
pkgbase = soundux
pkgdesc = A cross-platform soundboard - stable version
pkgver = 0.2.7
- pkgrel = 1
+ pkgrel = 2
url = https://soundux.rocks
+ install = soundux.install
arch = any
license = GPL3
+ makedepends = pkgconf
makedepends = cmake
makedepends = ninja
makedepends = pipewire
diff --git a/PKGBUILD b/PKGBUILD
index d7bb11d1c8cc..63c0f65a5329 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Nico <d3sox at protonmail dot com>
pkgname=soundux
pkgver=0.2.7
-pkgrel=1
+pkgrel=2
pkgdesc="A cross-platform soundboard - stable version"
arch=('any')
url="https://soundux.rocks"
license=('GPL3')
depends=('pulseaudio' 'webkit2gtk' 'libwnck3' 'libappindicator-gtk3' 'lsb-release')
optdepends=('youtube-dl: unmaintained downloader integration' 'yt-dlp-drop-in: recommended downloader integration' 'ffmpeg: downloader integration' 'pipewire: pipewire backend')
-makedepends=('cmake' 'ninja' 'pipewire')
+makedepends=('pkgconf' 'cmake' 'ninja' 'pipewire')
source=("https://github.com/Soundux/Soundux/releases/download/$pkgver/soundux-$pkgver.tar.gz")
sha256sums=('017003fc96f49df30575975f3904c0d8a500e325a9d2bca8c3dc69fed0cab0a7')
+install=soundux.install
build() {
cd "${srcdir}/Soundux"
diff --git a/soundux.install b/soundux.install
new file mode 100644
index 000000000000..84bc2a65b5d5
--- /dev/null
+++ b/soundux.install
@@ -0,0 +1,10 @@
+msg() {
+ printf "%b" "\e[1;31m==> WARNING: Currently there's a bug with the webkit2gtk version in Arch. If the window stays white try deleting ~/.local/share/mime/mime.cache\n"
+}
+
+post_install() {
+ msg
+}
+post_upgrade() {
+ msg
+}