summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3SOX2021-03-17 09:13:02 +0100
committerD3SOX2021-03-17 09:13:02 +0100
commitb959391dd73ae6cdebbb1667f90e44f636217d6b (patch)
treed54e9d05549c65c87e88f4517c51ad45959c4c15
parent1985d1dfef821fd6c17258efea16d2f21ea192f8 (diff)
downloadaur-b959391dd73ae6cdebbb1667f90e44f636217d6b.tar.gz
update to 0.2.2_b1, use upstream install, install doc and license
-rw-r--r--.SRCINFO7
-rwxr-xr-xPKGBUILD23
-rwxr-xr-xsoundux.desktop10
3 files changed, 13 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3be40928836..35efc8b8b317 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = soundux
pkgdesc = A cross-platform soundboard
- pkgver = 0.2.1
+ pkgver = 0.2.2_b1
pkgrel = 1
url = https://github.com/Soundux/Soundux
arch = any
@@ -12,10 +12,7 @@ pkgbase = soundux
depends = webkit2gtk
provides = soundux
conflicts = soundux
- source = git+https://github.com/Soundux/Soundux#tag=0.2.1
- source = soundux.desktop
+ source = git+https://github.com/Soundux/Soundux#tag=0.2.2_b1
sha256sums = SKIP
- sha256sums = 9ba572406c69e23c43ae419fde2bcefb4eade15e4e8ed9c082324b11d7e35184
pkgname = soundux
-
diff --git a/PKGBUILD b/PKGBUILD
index 789194473ceb..c4fddb9270e4 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Nico <d3sox at protonmail dot com>
pkgname=soundux
-pkgver=0.2.1
+pkgver=0.2.2_b1
pkgrel=1
pkgdesc="A cross-platform soundboard"
arch=('any')
@@ -10,8 +10,8 @@ depends=('pulseaudio' 'webkit2gtk')
makedepends=('git' 'cmake' 'ninja')
conflicts=('soundux')
provides=('soundux')
-source=("git+https://github.com/Soundux/Soundux#tag=$pkgver" "soundux.desktop")
-sha256sums=('SKIP' '9ba572406c69e23c43ae419fde2bcefb4eade15e4e8ed9c082324b11d7e35184')
+source=("git+https://github.com/Soundux/Soundux#tag=$pkgver")
+sha256sums=('SKIP')
build() {
cd "${srcdir}/Soundux"
@@ -23,15 +23,14 @@ build() {
}
package() {
- # install binary
- install -Dm 755 "${srcdir}/Soundux/build/soundux" "${pkgdir}/opt/soundux/soundux"
+ cd "${srcdir}/Soundux/build"
+ DESTDIR="$pkgdir/" ninja install
+ # install binary symlink
mkdir -p "${pkgdir}/usr/bin/"
ln -sf /opt/soundux/soundux "${pkgdir}/usr/bin/soundux"
- # install dist
- mkdir -p "${pkgdir}/opt/soundux/dist"
- cp -r "${srcdir}/Soundux/build/dist"/* "${pkgdir}/opt/soundux/dist"
- # install icon
- install -Dm 664 "${srcdir}/Soundux/assets/icon.png" "${pkgdir}/usr/share/pixmaps/soundux.png"
- # install desktop file
- install -Dm 644 "${srcdir}/soundux.desktop" "${pkgdir}/usr/share/applications/soundux.desktop"
+
+ # install doc
+ install -Dm 644 -t "${pkgdir}/usr/share/doc/${pkgname}" "${srcdir}/Soundux/README.md"
+ # install license
+ install -Dm 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "${srcdir}/Soundux/LICENSE"
}
diff --git a/soundux.desktop b/soundux.desktop
deleted file mode 100755
index 37cb46ab6908..000000000000
--- a/soundux.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Type=Application
-Version=1.0
-Name=Soundux
-GenericName=Soundboard
-Exec=/opt/soundux/soundux
-Icon=soundux
-Terminal=false
-Categories=Audio;Music;Player;AudioVideo;
-Comment=A universal soundboard using pulseaudio modules