summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAikawa Yataro2024-04-11 17:47:18 +0000
committerAikawa Yataro2024-04-11 17:47:18 +0000
commit0ed708bd38343cd654e3afd6d6c783a4600a3ca2 (patch)
treee8ea24024014215cb99dc14a83fe25cbd6f1f09b
downloadaur-0ed708bd38343cd654e3afd6d6c783a4600a3ca2.tar.gz
Add SourceGit.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD43
-rw-r--r--sourcegit.desktop7
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb941d410f95
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = sourcegit
+ pkgdesc = GUI client for GIT users
+ pkgver = 8.7
+ pkgrel = 1
+ url = https://github.com/sourcegit-scm/sourcegit
+ arch = x86_64
+ license = MIT
+ makedepends = dotnet-sdk-8.0
+ makedepends = libicns
+ depends = dotnet-runtime-8.0
+ depends = git
+ depends = git-credential-manager
+ depends = xdg-utils
+ source = sourcegit-8.7.tar.gz::https://github.com/sourcegit-scm/sourcegit/archive/refs/tags/v8.7.tar.gz
+ source = sourcegit.desktop
+ sha256sums = e8cdc3d96b7fe7a00d3d559da850ef48785cc3d624604637125bdf9617345f6e
+ sha256sums = 18e4e0df2b0ca3a50048f35cd193bd9b7f53e910ccd52c3405dead0bee1c3bc5
+
+pkgname = sourcegit
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..687b8df5309a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+
+!.gitignore
+!PKGBUILD
+!sourcegit.desktop
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22c688089b16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Aikawa Yataro <aikawayataro at protonmail dot com>
+
+pkgname=sourcegit
+pkgver=8.7
+pkgrel=1
+pkgdesc="GUI client for GIT users"
+arch=('x86_64')
+url='https://github.com/sourcegit-scm/sourcegit'
+license=('MIT')
+depends=('dotnet-runtime-8.0' 'git' 'git-credential-manager' 'xdg-utils')
+makedepends=('dotnet-sdk-8.0' 'libicns')
+
+source=("$pkgname-$pkgver.tar.gz::https://github.com/sourcegit-scm/sourcegit/archive/refs/tags/v$pkgver.tar.gz"
+ 'sourcegit.desktop')
+sha256sums=('e8cdc3d96b7fe7a00d3d559da850ef48785cc3d624604637125bdf9617345f6e'
+ '18e4e0df2b0ca3a50048f35cd193bd9b7f53e910ccd52c3405dead0bee1c3bc5')
+
+
+
+build() {
+ export DOTNET_CLI_TELEMETRY_OPTOUT=1
+ export DOTNET_SKIP_FIRST_TIME_EXPERIENCE=true
+
+ cd "$pkgname-$pkgver"
+
+ dotnet publish src/SourceGit.csproj -c Release -r linux-x64 -o publish -p:PublishAot=true -p:PublishTrimmed=true -p:TrimMode=link --self-contained
+ rm publish/SourceGit.dbg
+ icns2png -x -s 256x256 build/resources/App.icns 2>/dev/null
+}
+
+package() {
+ _bin=SourceGit
+
+ install -d "$pkgdir/opt/$pkgname/"
+ install -d "$pkgdir/usr/bin/"
+
+ cp -r "$srcdir/$pkgname-$pkgver/publish/"* "$pkgdir/opt/$pkgname/"
+ ln -s "/opt/sourcegit/SourceGit" "$pkgdir/usr/bin/$_bin"
+
+ install -Dm644 "sourcegit.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$srcdir/$pkgname-$pkgver/App_256x256x32.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps/$pkgname.png"
+ install -Dm644 "$srcdir/$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/sourcegit.desktop b/sourcegit.desktop
new file mode 100644
index 000000000000..603f90772934
--- /dev/null
+++ b/sourcegit.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=SourceGit
+Comment=Free & OpenSource Git Client
+Exec=SourceGit
+Icon=sourcegit
+Type=Application
+Terminal=false