summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Chen2015-10-07 18:44:33 +1300
committerAndrew Chen2015-10-07 18:44:33 +1300
commit61cfabe1c1d4bfee12e0545aa1850898aec0b445 (patch)
tree61360cdfc4dbfcb573ed48d6b4e862ef380a5e50
downloadaur-61cfabe1c1d4bfee12e0545aa1850898aec0b445.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0df367982256
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sourcery-codebench-mips-linux-gnu
+ pkgdesc = Sourcery CodeBench Lite 2015.05-18 for MIPS GNU/Linux
+ pkgver = 2015.05_18
+ pkgrel = 1
+ url = https://www.mentor.com/embedded-software/sourcery-tools/sourcery-codebench/editions/lite-edition/mips-gnu-linux
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = https://sourcery.mentor.com/GNUToolchain/package13838/public/mips-linux-gnu/mips-2015.05-18-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2
+ md5sums = 0fcdc0fee260c7bed060c999bfe8440d
+
+pkgname = sourcery-codebench-mips-linux-gnu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ac251d004ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Andrew Chen <andrew.chuanye.chen@gmail.com>
+
+pkgname=sourcery-codebench-mips-linux-gnu
+pkgver=2015.05_18
+pkgrel=1
+pkgdesc='Sourcery CodeBench Lite 2015.05-18 for MIPS GNU/Linux'
+url='https://www.mentor.com/embedded-software/sourcery-tools/sourcery-codebench/editions/lite-edition/mips-gnu-linux'
+arch=('i686' 'x86_64')
+license=('GPL')
+source=("https://sourcery.mentor.com/GNUToolchain/package13838/public/mips-linux-gnu/mips-${pkgver//_/-}-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2")
+md5sums=('0fcdc0fee260c7bed060c999bfe8440d')
+
+if [ "$CHARH" == 'x86_64' ]; then
+ depends=(lib32-glibc)
+fi
+
+package() {
+ cd mips-${pkgver%_*}
+ mkdir -p $pkgdir/usr
+ cp -a * $pkgdir/usr/
+ mkdir -p $pkgdir/usr/share/licenses/mips-linux-gnu
+ cp share/doc/mips-mips-linux-gnu/LICENSE.txt $pkgdir/usr/share/licenses/mips-linux-gnu/
+}