summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Băcîrcea2015-06-22 23:06:31 +0300
committerAdrian Băcîrcea2015-06-22 23:06:31 +0300
commitc1904d850e7ef8c5a2e301c6a46d3219dfecf349 (patch)
treeecb7b03e7068379c9e1f4ef239cd1b658b00bdb0
downloadaur-c1904d850e7ef8c5a2e301c6a46d3219dfecf349.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c59c61b705cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = sourceweb
+ pkgdesc = Source code indexer and code navigation tool for C/C++ code.
+ pkgver = r393.b6e24d4
+ pkgrel = 1
+ url = https://github.com/rprichard/sourceweb
+ arch = x86_64
+ license = BSD
+ makedepends = qt4
+ depends = qt4
+ depends = python
+ depends = clang
+ source = sourceweb::git+https://github.com/adytzu2007/sourceweb#branch=archlinux
+ sha256sums = SKIP
+
+pkgname = sourceweb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..672824fcb23c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# vim: set shiftwidth=3:
+# Maintainer: Adrian Bacircea <adrian.bacircea@gmail.com>
+pkgname=sourceweb
+pkgver=r393.b6e24d4
+pkgrel=1
+pkgdesc="Source code indexer and code navigation tool for C/C++ code."
+arch=('x86_64')
+url="https://github.com/rprichard/sourceweb"
+license=('BSD')
+depends=('qt4' 'python' 'clang')
+makedepends=('qt4')
+
+source=("${pkgname}::git+https://github.com/adytzu2007/sourceweb#branch=archlinux")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${pkgname}"
+
+ ./configure --prefix="/usr"
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make INSTALL_ROOT=${pkgdir} install
+}