summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Francois Chevrette2020-01-29 13:12:49 -0500
committerJean-Francois Chevrette2020-01-29 13:12:49 -0500
commit7c206d3c6660a36ab00a262fa8c3a40e965fe2be (patch)
tree06cf6db0469c6e139591c7b384faf73f7d92e1cc
downloadaur-7c206d3c6660a36ab00a262fa8c3a40e965fe2be.tar.gz
initial aur package for v0.12
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD68
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2335c2ee19d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sowm
+ pkgdesc = An itsy bitsy floating window manager
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/dylanaraps/sowm
+ arch = x86_64
+ license = MIT
+ depends = libx11
+ source = https://github.com/dylanaraps/sowm/archive/1.2.tar.gz
+ sha256sums = f69975670c015f3caf5f24ac448bd29cc215ae72458ca755c148c600dd2527ed
+
+pkgname = sowm
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f2045b2f0f26
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.tar.xz
+pkg/
+src/
+config.def.h
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96b331fc98bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Jean-Francois Chevrette <jfchevrette@gmail.com>
+
+pkgname=sowm
+pkgver=1.2
+pkgrel=1
+pkgdesc='An itsy bitsy floating window manager'
+arch=('x86_64')
+license=('MIT')
+depends=('libx11')
+url=https://github.com/dylanaraps/sowm
+source=(
+ https://github.com/dylanaraps/$pkgname/archive/$pkgver.tar.gz
+)
+sha256sums=(
+ 'f69975670c015f3caf5f24ac448bd29cc215ae72458ca755c148c600dd2527ed'
+)
+_sourcedir=$pkgname-$pkgver
+_makeopts=""
+
+prepare() {
+ # This package provides a mechanism to provide a custom config.h. Multiple
+ # configuration states are determined by the presence of two files in
+ # $BUILDDIR:
+ #
+ # config.h config.def.h state
+ # ======== ============ =====
+ # absent absent Initial state. The user receives a message on how
+ # to configure this package.
+ # absent present The user was previously made aware of the
+ # configuration options and has not made any
+ # configuration changes. The package is built using
+ # default values.
+ # present The user has supplied his or her configuration. The
+ # file will be copied to $srcdir and used during
+ # build.
+ #
+ # After this test, config.def.h is copied from $srcdir to $BUILDDIR to
+ # provide an up to date template for the user.
+ if [ -e "$BUILDDIR/config.h" ]
+ then
+ cp "$BUILDDIR/config.h" "$_sourcedir"
+ elif [ ! -e "$BUILDDIR/config.def.h" ]
+ then
+ msg='This package can be configured in config.h. Copy the config.def.h '
+ msg+='that was just placed into the package directory to config.h and '
+ msg+='modify it to change the configuration. Or just leave it alone to '
+ msg+='continue to use default values.'
+ warning "$msg"
+ fi
+ cp "$_sourcedir/config.def.h" "$BUILDDIR"
+}
+
+build() {
+ cd $_sourcedir
+ make $_makeopts
+}
+
+package() {
+ cd $_sourcedir
+ local installopts='--mode 0644 -D --target-directory'
+ local shrdir="$pkgdir/usr/share"
+ local licdir="$shrdir/licenses/$pkgname"
+ local docdir="$shrdir/doc/$pkgname"
+ make $_makeopts PREFIX=/usr DESTDIR="$pkgdir" install
+ install $installopts "$licdir" "LICENSE.md"
+ install $installopts "$docdir" "README.md"
+}
+