summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblackhole2015-10-22 17:55:21 +0200
committerblackhole2015-10-22 17:55:21 +0200
commitd126ad9f35e9b28490ee5e88102b9cf0bdcd8db2 (patch)
tree01445108803e17021b783cc46ec5c14df07bb8c6
downloadaur-d126ad9f35e9b28490ee5e88102b9cf0bdcd8db2.tar.gz
Initial import
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD38
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2360ce9fe32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = sox-dsd-git
+ pkgdesc = SoX Resampler library dsd branch
+ pkgver = sox.14.4.2.r12.gc05c760
+ pkgrel = 1
+ url = http://sox.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = libao
+ makedepends = libmad
+ makedepends = libid3tag
+ makedepends = wavpack
+ makedepends = libpulse
+ makedepends = opusfile
+ makedepends = autoconf
+ depends = libltdl
+ depends = file
+ depends = libsndfile
+ depends = libpng
+ depends = lame
+ depends = opencore-amr
+ depends = gsm
+ optdepends = libao: for ao plugin
+ optdepends = libmad: for mp3 plugin
+ optdepends = libid3tag: for mp3 plugin
+ optdepends = wavpack: for wavpack plugin
+ optdepends = libpulse: for pulse plugin
+ optdepends = opusfile: for opus plugin
+ provides = sox
+ conflicts = sox
+ source = sox-dsd-git::git://github.com/mansr/sox
+ sha256sums = SKIP
+
+pkgname = sox-dsd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9a1201c1f36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+
+pkgname=sox-dsd-git
+pkgver=sox.14.4.2.r12.gc05c760
+pkgrel=1
+pkgdesc="SoX Resampler library dsd branch"
+arch=('i686' 'x86_64')
+license=('GPL' 'LGPL')
+depends=('libltdl' 'file' 'libsndfile' 'libpng' 'lame' 'opencore-amr' 'gsm')
+makedepends=('libao' 'libmad' 'libid3tag' 'wavpack' 'libpulse' 'opusfile' 'autoconf')
+optdepends=('libao: for ao plugin'
+ 'libmad: for mp3 plugin'
+ 'libid3tag: for mp3 plugin'
+ 'wavpack: for wavpack plugin'
+ 'libpulse: for pulse plugin'
+ 'opusfile: for opus plugin')
+provides=('sox')
+conflicts=('sox')
+url="http://sox.sourceforge.net/"
+source=("$pkgname::git://github.com/mansr/sox")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $pkgname
+ autoreconf -i
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --with-distro="Arch Linux"
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+}