summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authort0nedef2015-08-29 17:45:19 -0400
committert0nedef2015-08-29 17:45:19 -0400
commit07977fbf614d1615aeed6237067268ab9901bb07 (patch)
tree800142cdc5607403c8103a6212ce5771877f89d6
downloadaur-07977fbf614d1615aeed6237067268ab9901bb07.tar.gz
move to aur4
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD20
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74fd797585c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = space-bg
+ pkgdesc = A background image setting program that grabs the daily astronomy image (http://apod.nasa.gov/apod/astropix.html)
+ pkgver = 2.0.7
+ pkgrel = 2
+ url = http://github.com/t0nedef/space-bg
+ arch = any
+ license = GPL
+ depends = hsetroot
+ depends = python-beautifulsoup4
+ depends = libnotify
+ depends = wget
+ depends = youtube-dl
+ depends = mplayer
+ depends = vimeo-dl-git
+ depends = imagemagick
+ source = https://github.com/t0nedef/space-bg/archive/2.0.7.tar.gz
+ md5sums = 0d93963b0d0e1a7ce04eec1a64021bf2
+
+pkgname = space-bg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a4d1a30535a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Aaron Ali <t0nedef@causal.ca>
+pkgname=space-bg
+pkgver=2.0.7
+pkgrel=2
+pkgdesc="A background image setting program that grabs the daily astronomy image (http://apod.nasa.gov/apod/astropix.html)"
+arch=('any')
+license=('GPL')
+url='http://github.com/t0nedef/space-bg'
+groups=()
+depends=('hsetroot' 'python-beautifulsoup4' 'libnotify' 'wget' 'youtube-dl' 'mplayer' 'vimeo-dl-git' 'imagemagick')
+source=("https://github.com/t0nedef/space-bg/archive/${pkgver}.tar.gz")
+package()
+{
+ cd ${srcdir}/${pkgname}-${pkgver}
+ install -Dm755 spacesetbg ${pkgdir}/usr/bin/spacesetbg
+ install -Dm755 spacevideo.sh ${pkgdir}/usr/bin/spacevideo.sh
+ install -Dm644 spaceimg.py ${pkgdir}/usr/lib/python3.4/site-packages/spaceimg.py
+}
+#
+md5sums=('0d93963b0d0e1a7ce04eec1a64021bf2')