summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-08 15:05:23 +0800
committerzxp198210052023-09-08 15:05:23 +0800
commitb045cbc6d4d0623273d4815b3c346b7646d9c63b (patch)
treeeacbc14f2e13824a3c5c1f2b948d50fd58235ad9
parentaaedfaf3ce50cce07fc00a5197286ac0ef173d27 (diff)
downloadaur-b045cbc6d4d0623273d4815b3c346b7646d9c63b.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66c5d66c13b1..af6f88131e93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = space-snake-bin
pkgdesc = A Desktop game built with Electron and Vue.js.
pkgver = 0.11.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ilyagru/Space-Snake
arch = x86_64
license = MIT
makedepends = gendesk
depends = bash
depends = electron4
+ provides = space-snake=0.11.1
+ conflicts = space-snake
source = space-snake-0.11.1.zip::https://github.com/ilyagru/Space-Snake/releases/download/0.11.1/Space-Snake-linux-x64-v0.11.1.zip
- source = space-snake.png::https://raw.githubusercontent.com/ilyagru/Space-Snake/master/app/icons/icon.png
+ source = space-snake.png::https://raw.githubusercontent.com/ilyagru/Space-Snake/0.11.1/app/icons/icon.png
source = space-snake.sh
sha256sums = b4ed62ff9b5dc3cc815f0ac5328dc602ce29f6bb3231beab622c246c7c2554f9
sha256sums = 2cf69008e16f9f81098eaed1b59e481bafb258606cc9171047db9b6fdec6cb9f
diff --git a/PKGBUILD b/PKGBUILD
index 03c3f3d8edca..782d761a71da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,29 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=space-snake-bin
+_pkgname=Space-Snake
pkgver=0.11.1
-pkgrel=2
+pkgrel=3
pkgdesc="A Desktop game built with Electron and Vue.js."
arch=('x86_64')
url="https://github.com/ilyagru/Space-Snake"
license=('MIT')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
depends=('bash' 'electron4')
makedepends=('gendesk')
-source=("${pkgname%-bin}-${pkgver}.zip::${url}/releases/download/${pkgver}/Space-Snake-linux-x64-v${pkgver}.zip"
- "${pkgname%-bin}.png::https://raw.githubusercontent.com/ilyagru/Space-Snake/master/app/icons/icon.png"
+source=("${pkgname%-bin}-${pkgver}.zip::${url}/releases/download/${pkgver}/${_pkgname}-linux-x64-v${pkgver}.zip"
+ "${pkgname%-bin}.png::https://raw.githubusercontent.com/ilyagru/Space-Snake/${pkgver}/app/icons/icon.png"
"${pkgname%-bin}.sh")
sha256sums=('b4ed62ff9b5dc3cc815f0ac5328dc602ce29f6bb3231beab622c246c7c2554f9'
'2cf69008e16f9f81098eaed1b59e481bafb258606cc9171047db9b6fdec6cb9f'
'db3df84cc0eb96fd548c4a0d507992883fdf4a0e7e449412caf5a37552e63eb1')
+prepare() {
+ gendesk -f -n --categories "Game" --name "${_pkgname}" --exec "${pkgname%-bin}"
+}
package() {
- bsdtar -xf "${srcdir}/${pkgname%-bin}-${pkgver}.zip"
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
- cp -r "${srcdir}/Space-Snake-linux-x64-v${pkgver}/resources/"* "${pkgdir}/opt/${pkgname%-bin}"
- install -Dm644 "${srcdir}/Space-Snake-linux-x64-v${pkgver}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
- gendesk -f -n --icon "${pkgname%-bin}" --categories "Game" --name "Space-Snake" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${_pkgname}-linux-x64-v${pkgver}/resources/"*.asar -t "${pkgdir}/opt/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${_pkgname}-linux-x64-v${pkgver}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
} \ No newline at end of file