summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-08 15:26:32 +0800
committerzxp198210052023-11-08 15:26:32 +0800
commitba60a5011b76be83690469a10b445984689678e4 (patch)
treec3313c9f17e3c9fd02e4d13f9dfbb51d07c58ec8
parentb045cbc6d4d0623273d4815b3c346b7646d9c63b (diff)
downloadaur-ba60a5011b76be83690469a10b445984689678e4.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD29
-rw-r--r--space-snake.sh5
3 files changed, 24 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af6f88131e93..b2bcd1659fc2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = space-snake-bin
pkgdesc = A Desktop game built with Electron and Vue.js.
pkgver = 0.11.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/ilyagru/Space-Snake
arch = x86_64
license = MIT
@@ -15,6 +15,6 @@ pkgbase = space-snake-bin
source = space-snake.sh
sha256sums = b4ed62ff9b5dc3cc815f0ac5328dc602ce29f6bb3231beab622c246c7c2554f9
sha256sums = 2cf69008e16f9f81098eaed1b59e481bafb258606cc9171047db9b6fdec6cb9f
- sha256sums = db3df84cc0eb96fd548c4a0d507992883fdf4a0e7e449412caf5a37552e63eb1
+ sha256sums = 884097a5e62f1fb7b904876fbe21295d04e5176aae04b5d433a644ffe219fdd8
pkgname = space-snake-bin
diff --git a/PKGBUILD b/PKGBUILD
index 782d761a71da..daeb09417876 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,35 @@
pkgname=space-snake-bin
_pkgname=Space-Snake
pkgver=0.11.1
-pkgrel=3
+pkgrel=4
pkgdesc="A Desktop game built with Electron and Vue.js."
arch=('x86_64')
url="https://github.com/ilyagru/Space-Snake"
license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('bash' 'electron4')
-makedepends=('gendesk')
-source=("${pkgname%-bin}-${pkgver}.zip::${url}/releases/download/${pkgver}/${_pkgname}-linux-x64-v${pkgver}.zip"
+depends=(
+ 'bash'
+ 'electron4'
+)
+makedepends=(
+ 'gendesk'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.zip::${url}/releases/download/${pkgver}/${_pkgname}-linux-x64-v${pkgver}.zip"
"${pkgname%-bin}.png::https://raw.githubusercontent.com/ilyagru/Space-Snake/${pkgver}/app/icons/icon.png"
- "${pkgname%-bin}.sh")
+ "${pkgname%-bin}.sh"
+)
sha256sums=('b4ed62ff9b5dc3cc815f0ac5328dc602ce29f6bb3231beab622c246c7c2554f9'
'2cf69008e16f9f81098eaed1b59e481bafb258606cc9171047db9b6fdec6cb9f'
- 'db3df84cc0eb96fd548c4a0d507992883fdf4a0e7e449412caf5a37552e63eb1')
-prepare() {
- gendesk -f -n --categories "Game" --name "${_pkgname}" --exec "${pkgname%-bin}"
+ '884097a5e62f1fb7b904876fbe21295d04e5176aae04b5d433a644ffe219fdd8')
+build() {
+ gendesk -q -f -n --categories "Game" --name "${_pkgname}" --exec "${pkgname%-bin}"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
- install -Dm644 "${srcdir}/${_pkgname}-linux-x64-v${pkgver}/resources/"*.asar -t "${pkgdir}/opt/${pkgname%-bin}"
- install -Dm644 "${srcdir}/${_pkgname}-linux-x64-v${pkgver}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/${_pkgname}-linux-x64-v${pkgver}/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
install -Dm644 "${srcdir}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/${_pkgname}-linux-x64-v${pkgver}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file
diff --git a/space-snake.sh b/space-snake.sh
index 5351d1420a9c..0512c9c8a80b 100644
--- a/space-snake.sh
+++ b/space-snake.sh
@@ -1,6 +1,9 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron4
-_ASAR="/opt/space-snake/app.asar"
+APPDIR=/usr/lib/space-snake
+export PATH="${APPDIR}:${PATH}"
+#export LD_LIBRARY_PATH="${APPDIR}/usr/lib:${LD_LIBRARY_PATH}"
+_ASAR="${APPDIR}/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else