summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0xGingi2023-08-14 00:40:54 -0400
committer0xGingi2023-08-14 00:40:54 -0400
commitd9cfeaa5456499feb16c98ce8aa37eb79265d024 (patch)
treec3f8bdca8d2d01c0c54352a23de9090438688d82
downloadaur-d9cfeaa5456499feb16c98ce8aa37eb79265d024.tar.gz
inital
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD52
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..662263c6bdb0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = spacebar-client-git
+ pkgdesc = Open source, themeable and extendable discord-compatible native Spacebar client
+ pkgver = r134.270c6c9
+ pkgrel = 1
+ url = https://github.com/spacebarchat/client
+ arch = any
+ license = AGPL3
+ makedepends = git
+ makedepends = nodejs
+ makedepends = npm
+ provides = spacebar-client
+ conflicts = spacebar-client
+ source = git+https://github.com/spacebarchat/client.git
+ source = git+https://github.com/0xGingi/spacebarchat-client-aur.git
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = spacebar-client-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c25695b0f773
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: 0xGingi <0xgingi@0xgingi.com>
+pkgname=('spacebar-client-git')
+pkgver=r134.270c6c9
+pkgrel=1
+pkgdesc="Open source, themeable and extendable discord-compatible native Spacebar client"
+arch=('any')
+url="https://github.com/spacebarchat/client"
+license=('AGPL3')
+makedepends=('git' 'nodejs' 'npm')
+provides=('spacebar-client')
+conflicts=('spacebar-client')
+source=("git+https://github.com/spacebarchat/client.git" "git+https://github.com/0xGingi/spacebarchat-client-aur.git")
+md5sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd client
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+prepare() {
+ cd spacebarchat-client-aur
+ sed -i "s|^User=.*\$|User=$USER|" spacebar-client.service
+}
+
+
+build() {
+ cd client
+ npm install
+ npm run build linux
+}
+
+package() {
+ cd client
+ install -d ${pkgdir}/opt/spacebar-client
+ cp -r build/* ${pkgdir}/opt/spacebar-client
+ sudo npm install -g serve
+ cd ${srcdir}/spacebarchat-client-aur
+ install -Dm0644 "spacebar-client.service" "${pkgdir}/etc/systemd/system/spacebar-client.service"
+
+ echo
+ echo
+ echo -------------------------------------------------------------
+ echo 'Spacebar-Client is now installed and running!'
+ echo 'Install location - /opt/spacebar-client'
+ echo 'Systemd Service - /etc/systemd/system/spacebar-client.service'
+ echo
+ echo 'Start the client with systemctl start spacebar-client'
+ echo 'Spacebar-Client will start at http://localhost:3000'
+ echo -------------------------------------------------------------
+ echo
+ echo
+}