summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcorey drew bruce2024-02-01 20:50:41 +1000
committercorey drew bruce2024-02-01 20:50:41 +1000
commitdb3bc1e6d112ba7154c818f22648bc0aae6b1d85 (patch)
treebdee5dffc648152a702391c6c3fa6e32fe911924
downloadaur-db3bc1e6d112ba7154c818f22648bc0aae6b1d85.tar.gz
Space Cadet Pinball
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0e17baba571
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = spacecadetpinball
+ pkgdesc = Space Cadet Pinball.
+ pkgver = 1.0.0
+ pkgrel = 1
+ arch = pentium4
+ arch = i386
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ license = GPL
+ makedepends = unzip
+ depends = scp-bin
+ depends = wget
+ depends = unzip
+ depends = yad
+ source = https://gitlab.com/spacecadetpinball/spacecadetpinball/-/archive/1.0.0-1/spacecadetpinball-1.0.0-1.tar.bz2
+ sha256sums = SKIP
+
+pkgname = spacecadetpinball
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..feda2fc59979
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+pkgname=spacecadetpinball
+_pkgname=SpaceCadetPinball
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Space Cadet Pinball."
+arch=('x86_64' 'aarch64')
+arch=('pentium4' 'i386' 'i686' 'x86_64' 'aarch64')
+license=('GPL')
+depends=('scp-bin' 'wget' 'unzip' 'yad')
+makedepends=('unzip')
+source=("https://gitlab.com/spacecadetpinball/spacecadetpinball/-/archive/$pkgver-$pkgrel/spacecadetpinball-$pkgver-$pkgrel.tar.bz2")
+sha256sums=("SKIP")
+
+package() {
+ install -dm755 "$pkgdir/usr/bin"
+ install -dm775 "$pkgdir/usr/share/games/$_pkgname"
+ install -dm755 "$pkgdir/usr/share/pixmaps"
+
+ # Packaging files
+ for dir in $pkgname-$pkgver-$pkgrel/ ; do mv "${dir}" "$pkgname" ;done
+ # Check if SpaceCadetPinball Assets zip exists so it doesn't redownload the file when it doesn't need to.
+ FILE="/usr/share/games/$_pkgname/3DPinball.zip"
+ if test -f "$FILE"
+ then
+ echo "$FILE exists skipping download."
+ cp -r /usr/share/games/SpaceCadetPinball/3DPinball.zip $pkgdir/usr/share/games/$_pkgname
+ else
+ echo "$FILE does not exist, Starting download.."
+ cd $srcdir/$pkgname
+ wget "https://archive.org/download/3DPinball/3DPinball.zip"
+ fi
+ cd $srcdir/$pkgname
+ cp "$srcdir/$pkgname/$pkgname" "$pkgdir/usr/bin"
+ cp -r ./ "$pkgdir/usr/share/games/$_pkgname"
+ cp $pkgname.png "$pkgdir/usr/share/pixmaps"
+
+ # Desktop Entry
+ install -Dm644 "$srcdir/$pkgname/$pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+ sed -i s%/usr/share%/opt% "$pkgdir/usr/share/applications/$pkgname.desktop"
+}