summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShohei Maruyama2024-02-05 22:53:14 +0900
committerShohei Maruyama2024-02-18 09:28:38 +0900
commiteba3cbfcbbb9169c90eb31a5493db09c012be919 (patch)
tree7852edd5b68fd55fba40e788eafe79c2e1ea5aeb
parenta87a18914f5379f26ca21685b5fd7222892b40e6 (diff)
downloadaur-eba3cbfcbbb9169c90eb31a5493db09c012be919.tar.gz
PKGBUILD: Update to 0.2.3
This commit updates sources to 0.2.3. This also updates toolchain's version because build failed by rust 1.73. Signed-off-by: Shohei Maruyama <cheat.sc.linux@outlook.com>
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7049fd953750..afad9e08a87f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = spacedrive
pkgdesc = Spacedrive is an open source cross-platform file explorer, powered by a virtual distributed filesystem written in Rust.
- pkgver = 0.2.2
+ pkgver = 0.2.3
pkgrel = 1
url = https://spacedrive.com/
arch = x86_64
license = AGPL3
- makedepends = cargo-nightly
+ makedepends = cargo
makedepends = pnpm
makedepends = clang
makedepends = git
+ makedepends = lld
depends = ffmpeg
depends = libheif
depends = gtk3
@@ -19,7 +20,7 @@ pkgbase = spacedrive
depends = libsoup
depends = glib2
conflicts = spacedrive-git
- source = spacedrive-v0.2.2.tar.gz::https://github.com/spacedriveapp/spacedrive/archive/refs/tags/0.2.2.tar.gz
- sha256sums = abd25ac7a7284cfd40994b83419d56bb680f82ef43bd3baac7dabbe00c145ee1
+ source = spacedrive-v0.2.3.tar.gz::https://github.com/spacedriveapp/spacedrive/archive/refs/tags/0.2.3.tar.gz
+ sha256sums = 7e722d52b90d137a37a2b28afb6d72dd67ef1e8e75f50ce56d00138f57812b1f
pkgname = spacedrive
diff --git a/PKGBUILD b/PKGBUILD
index b6a744febe0f..a4c914789420 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Shohei Maruyama <cheat.sc.linux@outlook.com>
pkgname='spacedrive'
-pkgver=0.2.2
+pkgver=0.2.3
pkgrel=1
pkgdesc='Spacedrive is an open source cross-platform file explorer, powered by a virtual distributed filesystem written in Rust.'
arch=('x86_64')
@@ -10,8 +10,8 @@ license=('AGPL3')
conflicts=('spacedrive-git')
source=("${pkgname}-v${pkgver}.tar.gz::https://github.com/spacedriveapp/spacedrive/archive/refs/tags/${pkgver}.tar.gz")
depends=('ffmpeg' 'libheif' 'gtk3' 'webkit2gtk' 'pango' 'gdk-pixbuf2' 'cairo' 'libsoup' 'glib2')
-makedepends=('cargo-nightly' 'pnpm' 'clang' 'git')
-sha256sums=('abd25ac7a7284cfd40994b83419d56bb680f82ef43bd3baac7dabbe00c145ee1')
+makedepends=('cargo' 'pnpm' 'clang' 'git' 'lld')
+sha256sums=('7e722d52b90d137a37a2b28afb6d72dd67ef1e8e75f50ce56d00138f57812b1f')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -23,7 +23,8 @@ build() {
cd "${pkgname}-${pkgver}"
export CARGO_TARGET_DIR=target
- export RUSTUP_TOOLCHAIN=1.73
+ export RUSTFLAGS='-Clinker-plugin-lto -Clinker=clang -Clink-arg=-fuse-ld=lld'
+ export CC=clang
pnpm prep
pnpm tauri build --bundles app -- --no-default-features