summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShohei Maruyama2024-02-04 23:23:27 +0900
committerShohei Maruyama2024-02-05 00:37:48 +0900
commitf40dc2dc9fbeac11bfa4e47c9a7fc0c100856224 (patch)
treeb21b75cb46386555cc6847046932cdba8d1e55b6
parent758cd1fcfd957443d2c8f4a37304539a7fc7ea5f (diff)
downloadaur-f40dc2dc9fbeac11bfa4e47c9a7fc0c100856224.tar.gz
PKGBUILD: Fix wrong build options
AI feature has been disabled at 582b230, but the approach is wrong because '--features' option does not override default features. Passing '--no-default-features' to 'cargo' from 'tauri' is correct. Signed-off-by: Shohei Maruyama <cheat.sc.linux@outlook.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3ecd9e6a8eb..cca49f2066c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spacedrive
pkgdesc = Spacedrive is an open source cross-platform file explorer, powered by a virtual distributed filesystem written in Rust.
pkgver = 0.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://spacedrive.com/
arch = x86_64
license = AGPL3
diff --git a/PKGBUILD b/PKGBUILD
index 0c24aab6e745..2cacd7da2241 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='spacedrive'
pkgver=0.2.1
-pkgrel=1
+pkgrel=2
pkgdesc='Spacedrive is an open source cross-platform file explorer, powered by a virtual distributed filesystem written in Rust.'
arch=('x86_64')
url='https://spacedrive.com/'
@@ -26,7 +26,7 @@ build() {
export RUSTUP_TOOLCHAIN=1.73
pnpm prep
- pnpm tauri build --bundles app --features custom-protocol
+ pnpm tauri build --bundles app -- --no-default-features
}
package() {