summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShohei Maruyama2023-12-02 22:27:07 +0900
committerShohei Maruyama2023-12-02 22:33:48 +0900
commit40c7c6928c1b47dff6331c3ed4baa006cc966241 (patch)
tree8b2f0bc9fd852498aa2a8cf990eb51ec0bdb40c8
parentd96933113bb4e9ae7031619c6f4dbd4f5edf8f36 (diff)
downloadaur-40c7c6928c1b47dff6331c3ed4baa006cc966241.tar.gz
PKGBUILD: Migrate 'pnpm prep' to build()
'pnpm prep' runs 'cargo' internally, so it should be in build(). Signed-off-by: Shohei Maruyama <cheat.sc.linux@outlook.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c82eea279f4..d14d773bf4eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spacedrive-git
pkgdesc = Spacedrive is an open source cross-platform file explorer, powered by a virtual distributed filesystem written in Rust.
pkgver = r2297.8ad468b
- pkgrel = 3
+ pkgrel = 4
url = https://spacedrive.com/
arch = x86_64
license = AGPL3
diff --git a/PKGBUILD b/PKGBUILD
index 190632c179ec..ee588c77eaab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='spacedrive-git'
pkgver=r2297.8ad468b
-pkgrel=3
+pkgrel=4
pkgdesc='Spacedrive is an open source cross-platform file explorer, powered by a virtual distributed filesystem written in Rust.'
arch=('x86_64')
url='https://spacedrive.com/'
@@ -21,10 +21,7 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
- export CARGO_TARGET_DIR=target
-
pnpm install
- pnpm prep
}
build() {
@@ -32,6 +29,7 @@ build() {
export CARGO_TARGET_DIR=target
+ pnpm prep
pnpm tauri build --bundles app
}