summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJanne Heß2017-03-09 11:51:01 +0100
committerJanne Heß2017-03-09 11:51:01 +0100
commit2c3ab56d1a34c2b9fda13801c14ba52750e888b3 (patch)
treedd626ff0cdf2e447d9c4d4dbbb638b2e0830956a
parentf60b476688c7111c056c068dc837379cde0dcf0a (diff)
downloadaur-2c3ab56d1a34c2b9fda13801c14ba52750e888b3.tar.gz
Fix dependencies and switch to GTK3
- Switch to GTK3 as we already depend on it - Add all optdeps spacefm can use - Switch to SHA512 - Reindent the PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 42 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2af30c9f2033..14f602465020 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Thu Mar 9 10:50:21 UTC 2017
pkgbase = spacefm
pkgdesc = Multi-panel tabbed file manager
pkgver = 1.0.5
- pkgrel = 2
+ pkgrel = 3
url = http://ignorantguru.github.com/spacefm/
arch = i686
arch = x86_64
@@ -9,16 +11,23 @@ pkgbase = spacefm
makedepends = intltool
makedepends = gettext
depends = gtk3
- depends = desktop-file-utils
depends = startup-notification
depends = ffmpegthumbnailer
+ optdepends = dbus: dbus integration
+ optdepends = util-linux: disk eject support
optdepends = lsof: device processes
optdepends = wget: plugin download
optdepends = gksu: perform as root functionality
optdepends = udevil: mount as non-root user and mount networks
optdepends = udisks2: mount as non-root user
- source = spacefm-1.0.5.tar.gz::https://github.com/IgnorantGuru/spacefm/archive/1.0.5.tar.gz
- md5sums = 634763f4d3886a00088e06a4295982b2
+ optdepends = pmount: mount as non-root user
+ optdepends = curlftpfs: mount FTP shares
+ optdepends = jmtpfs: mount MTP devices
+ optdepends = gphotofs: mount cameras
+ optdepends = ifuse: mount your iPhone/iPod Touch
+ optdepends = fuseiso: mount ISO files
+ source = https://github.com/IgnorantGuru/spacefm/archive/1.0.5.tar.gz
+ sha512sums = f32a59eac773df1bd9d36ba26cf7397bd205a2a8918e01f978c42ffb6aa2238a6f4dc871503a43f130c3b10d80f43364f54965d441f602ac895d0483fc073498
pkgname = spacefm
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ebff278cb2f1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.gz
+*.xz
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
index 91cc95f7ecbe..8e298f504872 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,44 @@
-# $Id: PKGBUILD 172395 2016-04-28 09:15:47Z eworm $
-# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+# Maintainer: Janne Heß <jannehess@gmail.com>
+# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
# Contributor: IgnorantGuru http://igurublog.wordpress.com/contact-ignorantguru/
# Contributor: ridikulus_rat <the.ridikulus.rat@gmail.com>
pkgname=spacefm
pkgver=1.0.5
-pkgrel=2
+pkgrel=3
pkgdesc='Multi-panel tabbed file manager'
arch=('i686' 'x86_64')
url='http://ignorantguru.github.com/spacefm/'
license=('GPL3')
-depends=('gtk3' 'desktop-file-utils' 'startup-notification' 'ffmpegthumbnailer')
+depends=('gtk3'
+ 'startup-notification'
+ 'ffmpegthumbnailer')
makedepends=('intltool' 'gettext')
-optdepends=('lsof: device processes'
+optdepends=('dbus: dbus integration'
+ 'util-linux: disk eject support'
+ 'lsof: device processes'
'wget: plugin download'
'gksu: perform as root functionality'
'udevil: mount as non-root user and mount networks'
- 'udisks2: mount as non-root user')
-source=($pkgname-$pkgver.tar.gz::https://github.com/IgnorantGuru/spacefm/archive/$pkgver.tar.gz)
-md5sums=('634763f4d3886a00088e06a4295982b2')
+ 'udisks2: mount as non-root user'
+ 'pmount: mount as non-root user'
+ 'curlftpfs: mount FTP shares'
+ 'jmtpfs: mount MTP devices'
+ 'gphotofs: mount cameras'
+ 'ifuse: mount your iPhone/iPod Touch'
+ 'fuseiso: mount ISO files')
+source=("https://github.com/IgnorantGuru/spacefm/archive/${pkgver}.tar.gz")
+sha512sums=('f32a59eac773df1bd9d36ba26cf7397bd205a2a8918e01f978c42ffb6aa2238a6f4dc871503a43f130c3b10d80f43364f54965d441f602ac895d0483fc073498')
build() {
- cd $pkgname-$pkgver
- ./configure --prefix=/usr \
- --disable-pixmaps
- make
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr \
+ --disable-pixmaps \
+ --with-gtk3
+ make
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}