summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-08-17 14:41:35 +0200
committerFabioLolix2018-08-17 14:41:35 +0200
commit71399c79168b4e079499249bf09fde2b6c25b55f (patch)
tree5d22f9beaaff3cca6cd9182fc2d088acfd89b243
parent44258a2107be0c8a855719e189afcb8457251139 (diff)
downloadaur-71399c79168b4e079499249bf09fde2b6c25b55f.tar.gz
fix glibc 2.28 build
-rw-r--r--.SRCINFO6
-rw-r--r--0001-glibc-2.28-compatibility.patch24
-rw-r--r--PKGBUILD13
3 files changed, 38 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10e39cd7b3f3..a10fa63a479a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = spacefm
pkgdesc = Multi-panel tabbed file manager
pkgver = 1.0.6
pkgrel = 1
- url = http://ignorantguru.github.com/spacefm/
+ url = https://ignorantguru.github.io/spacefm/
arch = i686
arch = x86_64
license = GPL3
@@ -24,8 +24,10 @@ pkgbase = spacefm
optdepends = gphotofs: mount cameras
optdepends = ifuse: mount your iPhone/iPod Touch
optdepends = fuseiso: mount ISO files
- source = https://github.com/IgnorantGuru/spacefm/archive/1.0.6.tar.gz
+ source = spacefm-1.0.6.tar.gz::https://github.com/IgnorantGuru/spacefm/archive/1.0.6.tar.gz
+ source = 0001-glibc-2.28-compatibility.patch
sha512sums = 37fc0dd31f02158502f592415b4c375ee49560af6f03d75b035d7c6c45bdc47064bba1ae8987b4cc8be2e02b3dfcdc17ec760411975e7b5f74343a2293fb2c8c
+ sha512sums = e6a6b2cca04a0e503480493c967725319a82938be1e431e437c49967f9b5da4e442502159fc1583981af5336d5a1213379c377776460b2431b92aecf5c3cb084
pkgname = spacefm
diff --git a/0001-glibc-2.28-compatibility.patch b/0001-glibc-2.28-compatibility.patch
new file mode 100644
index 000000000000..14e4dbaa6510
--- /dev/null
+++ b/0001-glibc-2.28-compatibility.patch
@@ -0,0 +1,24 @@
+From cb8cda4ec4200752caf8d297e9395f32ec2a81d8 Mon Sep 17 00:00:00 2001
+From: FabioLolix <fabio.lolix@gmail.com>
+Date: Fri, 17 Aug 2018 13:18:40 +0200
+Subject: [PATCH] glibc 2.28 compatibility
+
+---
+ src/main.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/main.c b/src/main.c
+index 27f5614..2b45708 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -23,6 +23,7 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
++#include <sys/sysmacros.h>
+
+ #include <signal.h>
+
+--
+2.18.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 4a60e9fd5e7c..6c3e8724e259 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgver=1.0.6
pkgrel=1
pkgdesc='Multi-panel tabbed file manager'
arch=('i686' 'x86_64')
-url='http://ignorantguru.github.com/spacefm/'
+url="https://ignorantguru.github.io/spacefm/"
license=('GPL3')
depends=('gtk3'
'startup-notification'
@@ -27,8 +27,15 @@ optdepends=('dbus: dbus integration'
'gphotofs: mount cameras'
'ifuse: mount your iPhone/iPod Touch'
'fuseiso: mount ISO files')
-source=("https://github.com/IgnorantGuru/spacefm/archive/${pkgver}.tar.gz")
-sha512sums=('37fc0dd31f02158502f592415b4c375ee49560af6f03d75b035d7c6c45bdc47064bba1ae8987b4cc8be2e02b3dfcdc17ec760411975e7b5f74343a2293fb2c8c')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/IgnorantGuru/spacefm/archive/${pkgver}.tar.gz"
+ 0001-glibc-2.28-compatibility.patch)
+sha512sums=('37fc0dd31f02158502f592415b4c375ee49560af6f03d75b035d7c6c45bdc47064bba1ae8987b4cc8be2e02b3dfcdc17ec760411975e7b5f74343a2293fb2c8c'
+ 'e6a6b2cca04a0e503480493c967725319a82938be1e431e437c49967f9b5da4e442502159fc1583981af5336d5a1213379c377776460b2431b92aecf5c3cb084')
+
+prepare() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ patch -Np1 -i ../0001-glibc-2.28-compatibility.patch
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"