summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2017-02-16 16:26:00 +0000
committerAntonio Rojas2017-02-16 16:26:00 +0000
commitf60b476688c7111c056c068dc837379cde0dcf0a (patch)
tree39bde550b72d62dfaee8e57d23df9dc7aa3cde27
downloadaur-f60b476688c7111c056c068dc837379cde0dcf0a.tar.gz
Dropped from community
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD33
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2af30c9f2033
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = spacefm
+ pkgdesc = Multi-panel tabbed file manager
+ pkgver = 1.0.5
+ pkgrel = 2
+ url = http://ignorantguru.github.com/spacefm/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = intltool
+ makedepends = gettext
+ depends = gtk3
+ depends = desktop-file-utils
+ depends = startup-notification
+ depends = ffmpegthumbnailer
+ optdepends = lsof: device processes
+ optdepends = wget: plugin download
+ optdepends = gksu: perform as root functionality
+ optdepends = udevil: mount as non-root user and mount networks
+ optdepends = udisks2: mount as non-root user
+ source = spacefm-1.0.5.tar.gz::https://github.com/IgnorantGuru/spacefm/archive/1.0.5.tar.gz
+ md5sums = 634763f4d3886a00088e06a4295982b2
+
+pkgname = spacefm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91cc95f7ecbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 172395 2016-04-28 09:15:47Z eworm $
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+# Contributor: IgnorantGuru http://igurublog.wordpress.com/contact-ignorantguru/
+# Contributor: ridikulus_rat <the.ridikulus.rat@gmail.com>
+
+pkgname=spacefm
+pkgver=1.0.5
+pkgrel=2
+pkgdesc='Multi-panel tabbed file manager'
+arch=('i686' 'x86_64')
+url='http://ignorantguru.github.com/spacefm/'
+license=('GPL3')
+depends=('gtk3' 'desktop-file-utils' 'startup-notification' 'ffmpegthumbnailer')
+makedepends=('intltool' 'gettext')
+optdepends=('lsof: device processes'
+ 'wget: plugin download'
+ 'gksu: perform as root functionality'
+ 'udevil: mount as non-root user and mount networks'
+ 'udisks2: mount as non-root user')
+source=($pkgname-$pkgver.tar.gz::https://github.com/IgnorantGuru/spacefm/archive/$pkgver.tar.gz)
+md5sums=('634763f4d3886a00088e06a4295982b2')
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-pixmaps
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}