summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskydrome2015-10-13 01:54:43 -0400
committerskydrome2015-10-13 01:54:43 -0400
commit8e67063e6b75bd70cdec2a27051cde39a4b038f4 (patch)
treea56509e240d3785ec1f73eb2154553ba3e617a51
parentc84213188f5d31d9febe843fb58b7efda66a9679 (diff)
downloadaur-8e67063e6b75bd70cdec2a27051cde39a4b038f4.tar.gz
revamp pkgbuild
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD73
-rw-r--r--spacefm.install (renamed from install)3
3 files changed, 41 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0493a0fa4f34..9e4f02170b7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,31 @@
pkgbase = spacefm-git
pkgdesc = A multi-panel tabbed file manager - git branch
- pkgver = 20150309.994
- pkgrel = 1
- url = http://ignorantguru.github.com/spacefm/
- install = install
+ pkgver = 20150919
+ pkgrel = 2
+ url = https://github.com/IgnorantGuru/spacefm
+ install = spacefm.install
arch = i686
arch = x86_64
license = GPL3
makedepends = intltool
makedepends = gettext
- depends = gtk3
depends = shared-mime-info
+ depends = hicolor-icon-theme
depends = desktop-file-utils
- depends = udev
+ depends = udevil
depends = ffmpegthumbnailer
+ depends = gtk3
optdepends = lsof: device processes
optdepends = eject: eject media
optdepends = wget: plugin download
- optdepends = ktsuss: perform as root functionality
optdepends = gksu: perform as root functionality
- optdepends = udevil-git: mount as non-root user and mount networks
optdepends = pmount: mount as non-root user
- optdepends = udisks: mount as non-root user
optdepends = udisks2: mount as non-root user
optdepends = startup-notification
+ optdepends = spacefm-plugin-clamav
provides = spacefm
conflicts = spacefm
- conflicts = spacefm-gtk2
- source = git+https://github.com/IgnorantGuru/spacefm#branch=next
+ source = git+https://github.com/IgnorantGuru/spacefm.git#branch=next
sha512sums = SKIP
pkgname = spacefm-git
diff --git a/PKGBUILD b/PKGBUILD
index a50ef8262a4f..33be818f0c80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,70 +1,57 @@
# Maintainer: flu
# Contributor: IgnorantGuru http://igurublog.wordpress.com/contact-ignorantguru/
-# Select favourite branch uncommenting only one of the following
-vcs_branch="next"
-#vcs_branch="master"
+GTK=3
-# Set USE_GDB=1 to build for gdb debugging, otherwise set USE_GDB=0
-USE_GDB=0
-
-_name="spacefm"
-pkgname="$_name-git"
-pkgver=20150309.994
-pkgrel=1
+pkgname="spacefm-git"
+pkgver=20150919
+pkgrel=2
pkgdesc="A multi-panel tabbed file manager - git branch"
arch=('i686' 'x86_64')
-url=("http://ignorantguru.github.com/$_name/")
+url=("https://github.com/IgnorantGuru/spacefm")
license=('GPL3')
+conflicts=("spacefm")
+provides=("spacefm")
+install='spacefm.install'
+[[ USE_GDB = 1 ]] && options=('!strip')
makedepends=('intltool' 'gettext')
-depends=('gtk3' 'shared-mime-info' 'desktop-file-utils' 'udev' 'ffmpegthumbnailer')
-optdepends=(
- 'lsof: device processes'
+depends=('shared-mime-info' 'hicolor-icon-theme' 'desktop-file-utils' 'udevil' 'ffmpegthumbnailer')
+optdepends=('lsof: device processes'
'eject: eject media'
'wget: plugin download'
- 'ktsuss: perform as root functionality'
'gksu: perform as root functionality'
- 'udevil-git: mount as non-root user and mount networks'
'pmount: mount as non-root user'
- 'udisks: mount as non-root user'
'udisks2: mount as non-root user'
'startup-notification'
-)
-conflicts=("$_name" "$_name-gtk2")
-provides=("$_name")
-source=(git+https://github.com/IgnorantGuru/$_name#branch=$vcs_branch)
-install="install"
-sha512sums=(SKIP)
-
+ 'spacefm-plugin-clamav')
-if (( USE_GDB == 1 )); then
- options=('!strip')
+if [[ "$GTK" = 2 ]]; then
+ depends+=('gtk2'); _opts='--with-gtk2'
+else
+ depends+=('gtk3'); _opts='--with-gtk3'
fi
+source=("git+https://github.com/IgnorantGuru/spacefm.git#branch=next")
+sha512sums=(SKIP)
+
pkgver() {
- cd "$srcdir"/"$_name"
- echo "$(git log -1 --format="%cd" --date=short | sed 's|-||g').$(git rev-list --count master)"
+ cd "$srcdir/spacefm"
+ git log -1 --format="%cd" --date=short |tr -d -
}
-build() {
-
- cd "$srcdir/$_name"
-
-
- if (( USE_GDB == 1 )); then
- export CFLAGS+="-g"
- fi
-
- # NOTE: To add a custom su program (mysu in this example), add:
- # --with-preferable-sudo="mysu" to configure line below.
+prepare() {
+ cd "$srcdir/spacefm"
+ ./autogen.sh --prefix=/usr $_opts
+}
- ./configure --prefix=/usr --with-gtk3
- make -s
+build() {
+ cd "$srcdir/spacefm"
+ make
}
package() {
- cd "${srcdir}/$_name"
- make DESTDIR="${pkgdir}/" install
+ cd "$srcdir/spacefm"
+ make DESTDIR="$pkgdir" install
}
diff --git a/install b/spacefm.install
index ad821a79bcbb..4f0b1ad17444 100644
--- a/install
+++ b/spacefm.install
@@ -1,8 +1,9 @@
post_install() {
- update-mime-database usr/share/mime > /dev/null
+ update-mime-database usr/share/mime
update-desktop-database -q
gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
gtk-update-icon-cache -q -t -f usr/share/icons/Faenza
+
}
post_upgrade() {