summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 16:19:47 -0600
committerBrian Bidulock2015-06-10 16:19:47 -0600
commita9dc47a18d3ea1ac588a407486220bb6846f8e80 (patch)
treee0d651b9f3df39ba7edea59c183de3771750c410
downloadaur-a9dc47a18d3ea1ac588a407486220bb6846f8e80.tar.gz
initial version
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD39
-rw-r--r--spacefm.install14
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3c56f2a816f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = spacefm-gtk2
+ pkgdesc = Multi-panel tabbed file manager
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = http://ignorantguru.github.com/spacefm/
+ install = spacefm.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = intltool
+ makedepends = gettext
+ depends = gtk2
+ depends = desktop-file-utils
+ depends = startup-notification
+ depends = ffmpegthumbnailer
+ optdepends = lsof: device processes
+ optdepends = wget: plugin download
+ optdepends = gksu: perform as root functionality
+ optdepends = udevil: mount as non-root user and mount networks
+ optdepends = udisks2: mount as non-root user
+ provides = spacefm
+ conflicts = spacefm
+ source = spacefm-1.0.2.tar.gz::https://github.com/IgnorantGuru/spacefm/archive/1.0.2.tar.gz
+ md5sums = cef34680fc5b76d8aefc1efa5e4b8824
+
+pkgname = spacefm-gtk2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1eb298cb0327
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: xekarfwtos <xekarfwtos@gmail.com>
+# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+# Contributor: jnbek <nospam@noemail.ru>
+# Contributor: IgnorantGuru http://igurublog.wordpress.com/contact-ignorantguru/
+# Contributor: ridikulus_rat <the.ridikulus.rat@gmail.com>
+
+pkgname=spacefm-gtk2
+_pkgname=spacefm
+pkgver=1.0.2
+pkgrel=1
+pkgdesc='Multi-panel tabbed file manager'
+arch=('i686' 'x86_64')
+url='http://ignorantguru.github.com/spacefm/'
+license=('GPL3')
+conflicts=('spacefm')
+provides=('spacefm')
+install=$_pkgname.install
+depends=('gtk2' 'desktop-file-utils' 'startup-notification' 'ffmpegthumbnailer')
+makedepends=('intltool' 'gettext')
+optdepends=('lsof: device processes'
+ 'wget: plugin download'
+ 'gksu: perform as root functionality'
+ 'udevil: mount as non-root user and mount networks'
+ 'udisks2: mount as non-root user')
+source=($_pkgname-$pkgver.tar.gz::https://github.com/IgnorantGuru/spacefm/archive/$pkgver.tar.gz)
+md5sums=('cef34680fc5b76d8aefc1efa5e4b8824')
+
+build() {
+ cd $_pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-pixmaps --with-gtk2
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
diff --git a/spacefm.install b/spacefm.install
new file mode 100644
index 000000000000..76a5d56b9884
--- /dev/null
+++ b/spacefm.install
@@ -0,0 +1,14 @@
+post_install() {
+ update-mime-database /usr/share/mime > /dev/null
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+ [[ -d /usr/share/icons/Faenza ]] && gtk-update-icon-cache -q -t -f /usr/share/icons/Faenza
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}