summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwereii2021-08-02 04:29:20 +0200
committerwereii2021-08-02 04:29:20 +0200
commit1f082f021d2393fafc6ab5caccb1c657c2a7aba3 (patch)
tree60194d339ad9de1d36ea72f04788bd1c82d1d3ed
downloadaur-1f082f021d2393fafc6ab5caccb1c657c2a7aba3.tar.gz
New package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1702af5836a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = spacestation14-launcher-bin
+ pkgdesc = Space Station 14 launcher
+ pkgver = 0.7.5
+ pkgrel = 1
+ url = https://spacestation14.io/
+ arch = x86_64
+ license = MIT
+ noextract = SS14.Launcher_Linux.zip
+ options = !strip
+ options = staticlibs
+ source = https://github.com/space-wizards/SS14.Launcher/releases/download/v0.7.5/SS14.Launcher_Linux.zip
+ sha256sums = 8001725e3fc371ed5029813fd6fd85cc971cb64def0ea47d0478172b58ba26d9
+
+pkgname = spacestation14-launcher-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7df9dcbc1068
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Tomas S. <me+aur at wereii.cz>
+# Contributor: Simon Perry <aur [at] sanxion [dot] net>
+# Contributor: Kochetkov Andrey <gornet@gmail.com>
+# Contributor: Fabian Schoelzel <myfirstname.mylastname@googlemail.com>
+
+pkgname=spacestation14-launcher-bin
+pkgver=0.7.5
+pkgrel=1
+pkgdesc="Space Station 14 launcher"
+url="https://spacestation14.io/"
+license=(MIT)
+arch=(x86_64)
+options=(!strip staticlibs)
+source=("https://github.com/space-wizards/SS14.Launcher/releases/download/v${pkgver}/SS14.Launcher_Linux.zip")
+noextract=("SS14.Launcher_Linux.zip")
+sha256sums=('8001725e3fc371ed5029813fd6fd85cc971cb64def0ea47d0478172b58ba26d9')
+
+
+prepare() {
+ cd "${srcdir}"
+ mkdir -p SS14; cd SS14
+ # it's important to run bsdtar outside of fakeroot
+ # as it acts differently with ownership data as root
+ bsdtar -x -f "${srcdir}/SS14.Launcher_Linux.zip"
+}
+
+package() {
+ mkdir -p "${pkgdir}/opt"
+ mv "${srcdir}/SS14" "${pkgdir}/opt"
+
+ install -dm755 "${pkgdir}/usr/bin"
+ cd "${pkgdir}/usr/bin"
+ ln -s "/opt/SS14/SS14.Launcher" "spacestation14-launcher"
+}