summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwereii2021-09-07 01:14:49 +0200
committerwereii2021-09-07 01:14:49 +0200
commitb077f55b5cf21a84da1144e59bc050a7bcaacc69 (patch)
treecc90351ab8276a0f1984a79e6a0b4bcfd6f22275
parentf51e77619517464f1e572d8723eadb0368c68a4a (diff)
downloadaur-b077f55b5cf21a84da1144e59bc050a7bcaacc69.tar.gz
Fixed invalid symlinks and added desktop file
Upstream .desktop file is patched for /opt install, also added Icon and tweaks
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
-rw-r--r--desktop.patch13
3 files changed, 36 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a38b07560347..65c16429a0b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spacestation14-launcher-bin
pkgdesc = Space Station 14 launcher
pkgver = 0.7.6
- pkgrel = 1
+ pkgrel = 2
url = https://spacestation14.io/
arch = x86_64
license = MIT
@@ -9,6 +9,10 @@ pkgbase = spacestation14-launcher-bin
options = !strip
options = staticlibs
source = SS14.launcher.v0.7.6.zip::https://github.com/space-wizards/SS14.Launcher/releases/download/v0.7.6/SS14.Launcher_Linux.zip
+ source = spacestation14.svg::https://spacestation14.io/images/main/icon.svg
+ source = desktop.patch
sha256sums = e11b245c3ec6a4c6c2b09e2b8f31b6814e446b8e10c6a76dc0053b01be065529
+ sha256sums = ba123bf55027694ffbf3528f58ba7554d072a023de3282187dd692f365ee9ce5
+ sha256sums = SKIP
pkgname = spacestation14-launcher-bin
diff --git a/PKGBUILD b/PKGBUILD
index 12931685c4db..3def5ca9e924 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=spacestation14-launcher-bin
pkgver=0.7.6
-pkgrel=1
+pkgrel=2
pkgdesc="Space Station 14 launcher"
url="https://spacestation14.io/"
license=(MIT)
@@ -10,9 +10,14 @@ arch=(x86_64)
options=(!strip staticlibs)
# sources need to have unique filenames
_source_name="SS14.launcher.v${pkgver}.zip"
-source=("${_source_name}::https://github.com/space-wizards/SS14.Launcher/releases/download/v${pkgver}/SS14.Launcher_Linux.zip")
+source=(
+ "${_source_name}::https://github.com/space-wizards/SS14.Launcher/releases/download/v${pkgver}/SS14.Launcher_Linux.zip"
+ "spacestation14.svg::https://spacestation14.io/images/main/icon.svg"
+ "desktop.patch")
noextract=("${_source_name}")
-sha256sums=('e11b245c3ec6a4c6c2b09e2b8f31b6814e446b8e10c6a76dc0053b01be065529')
+sha256sums=('e11b245c3ec6a4c6c2b09e2b8f31b6814e446b8e10c6a76dc0053b01be065529'
+ 'ba123bf55027694ffbf3528f58ba7554d072a023de3282187dd692f365ee9ce5'
+ 'SKIP')
prepare() {
@@ -20,7 +25,9 @@ prepare() {
mkdir -p SS14; cd SS14
# it's important to run bsdtar outside of fakeroot
# as it acts differently with ownership data as root
- bsdtar -x -f "${srcdir}/${_source_name}"
+ bsdtar -x -f "${srcdir}/${_source_name}"
+
+ patch "${srcdir}/SS14/SS14.desktop" "${srcdir}/desktop.patch"
}
package() {
@@ -28,5 +35,11 @@ package() {
mv "${srcdir}/SS14" "${pkgdir}/opt"
mkdir -p "${pkgdir}/usr/bin"
- ln -s "${pkgdir}/opt/SS14/SS14.Launcher" "${pkgdir}/usr/bin/spacestation14-launcher"
+ ln -s "/opt/SS14/SS14.Launcher" "${pkgdir}/usr/bin/spacestation14-launcher"
+
+ mkdir -p "${pkgdir}/usr/share/applications"
+ ln -s "/opt/SS14/SS14.desktop" "${pkgdir}/usr/share/applications/SS14.desktop"
+
+ mkdir -p "${pkgdir}/usr/share/pixmaps"
+ cp "${srcdir}/spacestation14.svg" "${pkgdir}/usr/share/pixmaps"
}
diff --git a/desktop.patch b/desktop.patch
new file mode 100644
index 000000000000..445a83751122
--- /dev/null
+++ b/desktop.patch
@@ -0,0 +1,13 @@
+1d0
+< #!/usr/bin/env xdg-open
+3d1
+< Encoding=UTF-8
+5,6d2
+< Type=Application
+< Exec=env ./SS14.Launcher %u
+7a4,8
+> Type=Application
+> Exec=spacestation14-launcher
+> Icon=/usr/share/pixmaps/spacestation14.svg
+> Terminal=false
+> Categories=Game;