summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwereii2021-09-04 18:59:23 +0200
committerwereii2021-09-04 18:59:23 +0200
commitf51e77619517464f1e572d8723eadb0368c68a4a (patch)
tree165248ae2d5f845f4c72825caa779c1a20fa2bcc
parent1f082f021d2393fafc6ab5caccb1c657c2a7aba3 (diff)
downloadaur-f51e77619517464f1e572d8723eadb0368c68a4a.tar.gz
Update to 0.7.6
- fixed missed pkgdir prefix in symlink creation - removed invalid contributors (pkgbuild copy-paste misshap)
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD20
3 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1702af5836a..a38b07560347 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = spacestation14-launcher-bin
pkgdesc = Space Station 14 launcher
- pkgver = 0.7.5
+ pkgver = 0.7.6
pkgrel = 1
url = https://spacestation14.io/
arch = x86_64
license = MIT
- noextract = SS14.Launcher_Linux.zip
+ noextract = SS14.launcher.v0.7.6.zip
options = !strip
options = staticlibs
- source = https://github.com/space-wizards/SS14.Launcher/releases/download/v0.7.5/SS14.Launcher_Linux.zip
- sha256sums = 8001725e3fc371ed5029813fd6fd85cc971cb64def0ea47d0478172b58ba26d9
+ source = SS14.launcher.v0.7.6.zip::https://github.com/space-wizards/SS14.Launcher/releases/download/v0.7.6/SS14.Launcher_Linux.zip
+ sha256sums = e11b245c3ec6a4c6c2b09e2b8f31b6814e446b8e10c6a76dc0053b01be065529
pkgname = spacestation14-launcher-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..970e83b3126f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.zst
+*.zip
+*.tar
diff --git a/PKGBUILD b/PKGBUILD
index 7df9dcbc1068..12931685c4db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
# Maintainer: Tomas S. <me+aur at wereii.cz>
-# Contributor: Simon Perry <aur [at] sanxion [dot] net>
-# Contributor: Kochetkov Andrey <gornet@gmail.com>
-# Contributor: Fabian Schoelzel <myfirstname.mylastname@googlemail.com>
pkgname=spacestation14-launcher-bin
-pkgver=0.7.5
+pkgver=0.7.6
pkgrel=1
pkgdesc="Space Station 14 launcher"
url="https://spacestation14.io/"
license=(MIT)
arch=(x86_64)
options=(!strip staticlibs)
-source=("https://github.com/space-wizards/SS14.Launcher/releases/download/v${pkgver}/SS14.Launcher_Linux.zip")
-noextract=("SS14.Launcher_Linux.zip")
-sha256sums=('8001725e3fc371ed5029813fd6fd85cc971cb64def0ea47d0478172b58ba26d9')
+# sources need to have unique filenames
+_source_name="SS14.launcher.v${pkgver}.zip"
+source=("${_source_name}::https://github.com/space-wizards/SS14.Launcher/releases/download/v${pkgver}/SS14.Launcher_Linux.zip")
+noextract=("${_source_name}")
+sha256sums=('e11b245c3ec6a4c6c2b09e2b8f31b6814e446b8e10c6a76dc0053b01be065529')
prepare() {
@@ -21,14 +20,13 @@ prepare() {
mkdir -p SS14; cd SS14
# it's important to run bsdtar outside of fakeroot
# as it acts differently with ownership data as root
- bsdtar -x -f "${srcdir}/SS14.Launcher_Linux.zip"
+ bsdtar -x -f "${srcdir}/${_source_name}"
}
package() {
mkdir -p "${pkgdir}/opt"
mv "${srcdir}/SS14" "${pkgdir}/opt"
- install -dm755 "${pkgdir}/usr/bin"
- cd "${pkgdir}/usr/bin"
- ln -s "/opt/SS14/SS14.Launcher" "spacestation14-launcher"
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s "${pkgdir}/opt/SS14/SS14.Launcher" "${pkgdir}/usr/bin/spacestation14-launcher"
}