summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Derumigny2021-11-15 00:23:11 +0100
committerNicolas Derumigny2021-11-15 00:23:11 +0100
commit4e13e2544888c77961b21928ecb5fe943de86c3b (patch)
tree24a76f0b4f625b361575c9e7f734fbe16e16a37f
parent86661980de949d9d4219933be0f3f31cbe733929 (diff)
downloadaur-4e13e2544888c77961b21928ecb5fe943de86c3b.tar.gz
Update to spack 17.0.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--spack.env.sh.patch45
3 files changed, 35 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 260227048d3b..d586de40b79c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spack
pkgdesc = A flexible package manager for supercomputer that supports multiple versions, configurations, platforms, and compilers.
- pkgver = 0.16.3
+ pkgver = 0.17.0
pkgrel = 1
url = https://spack.io/
arch = i686
@@ -10,7 +10,7 @@ pkgbase = spack
depends = polkit
optdepends = env-modules-tcl
optdepends = lmod
- source = spack-0.16.3.tar.gz::https://github.com/spack/spack/archive/v0.16.3.tar.gz
+ source = spack-0.17.0.tar.gz::https://github.com/spack/spack/archive/v0.17.0.tar.gz
source = spack.sysusers
source = spack.tmpfiles
source = spack.pkaction
@@ -19,7 +19,7 @@ pkgbase = spack
source = spack.csh
source = spack.bin.py
source = spack.env.sh.patch
- sha256sums = 26636a2e2cc066184f12651ac6949f978fc041990dba73934960a4c9c1ea383d
+ sha256sums = 93df99256a892ceefb153d48e2080c01d18e58e27773da2c2a469063d67cb582
sha256sums = e6d46e8f5140b4e86596d38f23af379d9adce8e9afc66f800571d7a4d9211e19
sha256sums = db0cc4a4ab32e6ee2e5c32898c69a0f0ce05b4e3c605beb024b5463c46e3710f
sha256sums = 1f2c4c6b8841d927fa4056206b8e5603719c0d829586ff0937efaa935d054376
diff --git a/PKGBUILD b/PKGBUILD
index 34c0199f5dd3..cf9a9c8edaca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
-# Maintainer: Guillaume Dolle <dev at gdolle.com>
+# Maintainer: Nicolas Derumigny nderumigny <at> gmail <dot> com
pkgname=spack
-pkgver=0.16.3
+pkgver=0.17.0
pkgrel=1
pkgdesc="A flexible package manager for supercomputer that supports multiple versions, configurations, platforms, and compilers."
arch=('i686' 'x86_64')
@@ -20,7 +20,7 @@ source=(
spack.env.sh.patch
)
sha256sums=(
- '26636a2e2cc066184f12651ac6949f978fc041990dba73934960a4c9c1ea383d'
+ '93df99256a892ceefb153d48e2080c01d18e58e27773da2c2a469063d67cb582'
'e6d46e8f5140b4e86596d38f23af379d9adce8e9afc66f800571d7a4d9211e19'
'db0cc4a4ab32e6ee2e5c32898c69a0f0ce05b4e3c605beb024b5463c46e3710f'
'1f2c4c6b8841d927fa4056206b8e5603719c0d829586ff0937efaa935d054376'
@@ -28,7 +28,7 @@ sha256sums=(
'0bddb0a0f1d470509f44c3031041ab0de5472de84f58c90d4b6c91e6782cb6a2'
'7b427625d7890dbc0ae493da095a4d7de47742fd3b02e3f42d7ee52e3599a4ac'
'70ac76748d40d93fb5e5597fbaae933756c4eeb0b8969255e16435d0fad60006'
- '6b850208af0788222de1a14989cb52289e2c7ecd7455e121ceb990e4079c6ed5'
+ '3249ca591216ca118f5a778dc9c0ba27d2f66e1a685fa101511a06bfa09a0d13'
)
_spackroot=/opt/spack
_spackcfg=etc/spack/defaults/config.yaml
diff --git a/spack.env.sh.patch b/spack.env.sh.patch
index 26f9e4f3bc48..405257d54140 100644
--- a/spack.env.sh.patch
+++ b/spack.env.sh.patch
@@ -1,16 +1,17 @@
---- share/spack/setup-env.sh 2021-02-19 20:06:33.000000000 +0100
-+++ share/spack/setup-env.sh 2021-03-03 12:23:39.557249552 +0100
-@@ -45,6 +45,9 @@
+--- share/spack/setup-env.sh 2021-11-15 00:06:07.160481958 +0100
++++ share/spack/setup-env.sh 2021-11-15 00:09:10.820476320 +0100
+@@ -45,6 +45,10 @@
fi
export _sp_initializing=true
+_pkexec_env() {
+ /usr/bin/spack $@
+}
++
_spack_shell_wrapper() {
# Store LD_LIBRARY_PATH variables from spack shell function
-@@ -75,7 +78,7 @@
+@@ -75,7 +79,7 @@
[ "${_sp_flags#*h}" != "${_sp_flags}" ] || \
[ "${_sp_flags#*V}" != "${_sp_flags}" ];
then
@@ -19,7 +20,7 @@
return
fi
-@@ -96,7 +99,7 @@
+@@ -96,7 +100,7 @@
shift
fi
if [ "$_sp_arg" = "-h" ] || [ "$_sp_arg" = "--help" ]; then
@@ -28,7 +29,7 @@
else
LOC="$(spack location $_sp_arg "$@")"
if [ -d "$LOC" ] ; then
-@@ -115,7 +118,7 @@
+@@ -115,7 +119,7 @@
fi
if [ "$_sp_arg" = "-h" ] || [ "$_sp_arg" = "--help" ]; then
@@ -37,7 +38,7 @@
else
case $_sp_arg in
activate)
-@@ -133,10 +136,10 @@
+@@ -133,10 +137,10 @@
[ "${_a#* --help}" != "$_a" ];
then
# No args or args contain --sh, --csh, or -h/--help: just execute.
@@ -45,12 +46,12 @@
+ _pkexec_env env activate "$@"
else
# Actual call to activate: source the output.
-- eval $(command spack $_sp_flags env activate --sh "$@")
-+ eval $(_pkexec_env $_sp_flags env activate --sh "$@")
+- stdout="$(command spack $_sp_flags env activate --sh "$@")" || return
++ stdout="$(_pkexec_env $_sp_flags env activate --sh "$@")" || return
+ eval "$stdout"
fi
;;
- deactivate)
-@@ -151,17 +154,17 @@
+@@ -152,18 +156,18 @@
[ "${_a#* --csh}" != "$_a" ];
then
# Args contain --sh or --csh: just execute.
@@ -62,8 +63,9 @@
+ _pkexec_env env deactivate -h
else
# No args: source the output of the command.
-- eval $(command spack $_sp_flags env deactivate --sh)
-+ eval $(_pkexec_env $_sp_flags env deactivate --sh)
+- stdout="$(command spack $_sp_flags env deactivate --sh)" || return
++ stdout="$(_pkexec_env $_sp_flags env deactivate --sh)" || return
+ eval "$stdout"
fi
;;
*)
@@ -72,16 +74,16 @@
;;
esac
fi
-@@ -181,14 +184,14 @@
+@@ -184,14 +188,14 @@
[ "${_a#* --help}" != "$_a" ];
then
# Args contain --sh, --csh, or -h/--help: just execute.
- command spack $_sp_flags $_sp_subcommand "$@"
+ _pkexec_env $_sp_flags $_sp_subcommand "$@"
else
-- eval $(command spack $_sp_flags $_sp_subcommand --sh "$@" || \
-+ eval $(_pkexec_env $_sp_flags $_sp_subcommand --sh "$@" || \
- echo "return 1") # return 1 if spack command fails
+- stdout="$(command spack $_sp_flags $_sp_subcommand --sh "$@")" || return
++ stdout="$(_pkexec_env $_sp_flags $_sp_subcommand --sh "$@")" || return
+ eval "$stdout"
fi
;;
*)
@@ -90,3 +92,12 @@
;;
esac
}
+@@ -366,7 +370,7 @@
+ _spack_pathadd PATH "${_sp_module_bin}"
+ fi;
+ else
+- stdout="$(command spack --print-shell-vars sh)" || return
++ stdout="$(_pkexec_env --print-shell-vars sh)" || return
+ eval "$stdout"
+ fi;
+