summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeert Hendrickx2021-10-06 21:43:15 +0200
committerGeert Hendrickx2021-10-06 21:43:15 +0200
commit0b0a005041143219cb61256d2837e3c5593dbe29 (patch)
treef8f59652c5769954aea12d89229070b64271c436
parentdb67e0cdd1254d57e5083586211a01ce6ba97b13 (diff)
downloadaur-0b0a005041143219cb61256d2837e3c5593dbe29.tar.gz
Revert, -O0 works better for now (segfaults happen with gif and png, too).
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e90c3eccf2c..d1eaa6516234 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = spamprobe
pkgdesc = Fast, intelligent, automatic spam detector using Paul Graham style Bayesian analysis of word counts in spam and non-spam emails
pkgver = 1.4d
- pkgrel = 10
+ pkgrel = 9
url = http://spamprobe.sourceforge.net/
arch = i686
arch = x86_64
license = custom:QPL
depends = db
depends = giflib
+ depends = libjpeg
depends = libpng
source = http://downloads.sourceforge.net/spamprobe/spamprobe-1.4d.tar.gz
source = spamprobe-db5.patch
diff --git a/PKGBUILD b/PKGBUILD
index 2a467cbe33cc..2cd16d999c0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=spamprobe
pkgver=1.4d
-pkgrel=10
+pkgrel=9
pkgdesc="Fast, intelligent, automatic spam detector using Paul Graham style Bayesian analysis of word counts in spam and non-spam emails"
arch=(i686 x86_64)
url="http://spamprobe.sourceforge.net/"
license=('custom:QPL')
-depends=(db giflib libpng)
+depends=(db giflib libjpeg libpng)
source=(http://downloads.sourceforge.net/spamprobe/$pkgname-$pkgver.tar.gz
spamprobe-db5.patch spamprobe-gcc43.patch spamprobe-png.patch
spamprobe-template.patch spamprobe-giflib.patch
@@ -29,7 +29,8 @@ build() {
patch -p0 -i $srcdir/spamprobe-template.patch
patch -p0 -i $srcdir/spamprobe-giflib.patch
patch -p0 -i $srcdir/spamprobe-lrucache.patch
- ./configure --prefix=/usr --mandir=/usr/share/man --without-jpeg
+ CXXFLAGS+=" -O0"
+ ./configure --prefix=/usr --mandir=/usr/share/man
make
}