summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeert Hendrickx2021-10-06 23:04:42 +0200
committerGeert Hendrickx2021-10-06 23:04:42 +0200
commit983874bf462c2e914a524bf50286997bef02ad75 (patch)
treed46c6c445f9d3e3ab84c488d39b2be91ba27dcfe
parent0b0a005041143219cb61256d2837e3c5593dbe29 (diff)
downloadaur-983874bf462c2e914a524bf50286997bef02ad75.tar.gz
Proper fix.
warning: control reaches end of non-void function [-Wreturn-type]
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--spamprobe-returntype.patch30
3 files changed, 38 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1eaa6516234..e6f34a856822 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spamprobe
pkgdesc = Fast, intelligent, automatic spam detector using Paul Graham style Bayesian analysis of word counts in spam and non-spam emails
pkgver = 1.4d
- pkgrel = 9
+ pkgrel = 10
url = http://spamprobe.sourceforge.net/
arch = i686
arch = x86_64
@@ -17,6 +17,7 @@ pkgbase = spamprobe
source = spamprobe-template.patch
source = spamprobe-giflib.patch
source = spamprobe-lrucache.patch
+ source = spamprobe-returntype.patch
sha256sums = 217ce47dcc6f58d8201fbb0a5e2dc38b5b06349fadb1378fb3647ad8a3f44d68
sha256sums = 74c047a55a6e9a553bee29b5f46725b43821fa29630e2ca2ab348ea0852d070d
sha256sums = 2f1a60295b2832a8c174efb2efa3d54a9268235795560b35a63f2b31bfd59019
@@ -24,5 +25,6 @@ pkgbase = spamprobe
sha256sums = 220523fb2e7e5c94d1f01cf54052e7bf3124bf342779953abe1355789129e621
sha256sums = af1a610bee4f4d4ad68267b88278d837ecde271e371342497f1b048e528d7d36
sha256sums = 9814777be778cec4987efc17963296a1429bdd15c7a392e54111af137d8ebc72
+ sha256sums = 8ae6a79bbce3e59e42d0cbbdaef6dd98399472e6de2703ab90cb8b4580b3ccee
pkgname = spamprobe
diff --git a/PKGBUILD b/PKGBUILD
index 2cd16d999c0e..340c15fd8153 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=spamprobe
pkgver=1.4d
-pkgrel=9
+pkgrel=10
pkgdesc="Fast, intelligent, automatic spam detector using Paul Graham style Bayesian analysis of word counts in spam and non-spam emails"
arch=(i686 x86_64)
url="http://spamprobe.sourceforge.net/"
@@ -12,14 +12,15 @@ depends=(db giflib libjpeg libpng)
source=(http://downloads.sourceforge.net/spamprobe/$pkgname-$pkgver.tar.gz
spamprobe-db5.patch spamprobe-gcc43.patch spamprobe-png.patch
spamprobe-template.patch spamprobe-giflib.patch
- spamprobe-lrucache.patch)
+ spamprobe-lrucache.patch spamprobe-returntype.patch)
sha256sums=('217ce47dcc6f58d8201fbb0a5e2dc38b5b06349fadb1378fb3647ad8a3f44d68'
'74c047a55a6e9a553bee29b5f46725b43821fa29630e2ca2ab348ea0852d070d'
'2f1a60295b2832a8c174efb2efa3d54a9268235795560b35a63f2b31bfd59019'
'3e99cf08dab2a461e1afada44d809dee2407ec990b3e76175fc026cda2830ded'
'220523fb2e7e5c94d1f01cf54052e7bf3124bf342779953abe1355789129e621'
'af1a610bee4f4d4ad68267b88278d837ecde271e371342497f1b048e528d7d36'
- '9814777be778cec4987efc17963296a1429bdd15c7a392e54111af137d8ebc72')
+ '9814777be778cec4987efc17963296a1429bdd15c7a392e54111af137d8ebc72'
+ '8ae6a79bbce3e59e42d0cbbdaef6dd98399472e6de2703ab90cb8b4580b3ccee')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -29,7 +30,7 @@ build() {
patch -p0 -i $srcdir/spamprobe-template.patch
patch -p0 -i $srcdir/spamprobe-giflib.patch
patch -p0 -i $srcdir/spamprobe-lrucache.patch
- CXXFLAGS+=" -O0"
+ patch -p0 -i $srcdir/spamprobe-returntype.patch
./configure --prefix=/usr --mandir=/usr/share/man
make
}
diff --git a/spamprobe-returntype.patch b/spamprobe-returntype.patch
new file mode 100644
index 000000000000..4f356bdf4923
--- /dev/null
+++ b/spamprobe-returntype.patch
@@ -0,0 +1,30 @@
+--- src/parser/PngParser.cc.orig 2021-10-06 22:49:53.369697387 +0200
++++ src/parser/PngParser.cc 2021-10-06 22:51:06.073959192 +0200
+@@ -68,6 +68,7 @@
+ } catch (runtime_error &ex) {
+ return false;
+ }
++ return true;
+ }
+
+ void PngParser::initializeImage()
+--- src/parser/JpegParser.cc.orig 2006-11-17 08:11:08.000000000 +0100
++++ src/parser/JpegParser.cc 2021-10-06 22:51:11.387360545 +0200
+@@ -64,6 +64,7 @@
+ } catch (runtime_error &ex) {
+ return false;
+ }
++ return true;
+ }
+
+ void JpegParser::tokenizeMarker(const string &base_token,
+--- src/parser/GifParser.cc.orig 2021-10-06 22:49:53.373030763 +0200
++++ src/parser/GifParser.cc 2021-10-06 22:51:18.017445447 +0200
+@@ -94,6 +94,7 @@
+ } catch (runtime_error &ex) {
+ return false;
+ }
++ return true;
+ }
+
+ void GifParser::openImage()