summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClarence2020-12-16 13:20:40 +0800
committerClarence2020-12-16 13:20:40 +0800
commit409947e9d04948b7cbf43c83b922eacc6e9bf4c9 (patch)
treef106e18e0eea083cf8f7ec390badbbcee6ed8ba0
parent8503040e13a8cffe29cac2a2ca5727ecc5641642 (diff)
downloadaur-409947e9d04948b7cbf43c83b922eacc6e9bf4c9.tar.gz
add spandsp tests.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3844e42ae0aa..d6a3cd5bf124 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,8 @@ pkgbase = spandsp-fs
license = LGPL
license = GPL
makedepends = gawk
+ makedepends = sox
+ makedepends = fftw
depends = libtiff
provides = spandsp
conflicts = spandsp
diff --git a/PKGBUILD b/PKGBUILD
index 41291967096c..57d4433c026f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,25 +8,31 @@ arch=('x86_64')
url="https://github.com/freeswitch/spandsp"
license=('LGPL' 'GPL')
depends=('libtiff')
-makedepends=('gawk')
+makedepends=('gawk' 'sox' 'fftw')
provides=('spandsp')
conflicts=('spandsp')
source=("git+https://github.com/freeswitch/$_pkgname")
sha256sums=('SKIP')
pkgver() {
- cd $srcdir/$_pkgname
+ cd "$_pkgname"
awk '/^Version:/ { print $2 }' spandsp.spec
}
build() {
cd "$_pkgname"
./autogen.sh
- ./configure --prefix=/usr
- make
+ ./configure --prefix=/usr --enable-tests
+ make -C src
+}
+
+check() {
+ cd "$_pkgname"
+ make check
}
package() {
cd "$_pkgname"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" -C src install
+ make DESTDIR="$pkgdir" install-pkgconfigDATA
}