summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClarence2020-12-16 13:46:40 +0800
committerClarence2020-12-16 13:46:40 +0800
commit785bc2c0514a29f50fedfeca9638da740d79ff3c (patch)
tree45fac48e0cad14618f21dc20acc755ab56856712
parent409947e9d04948b7cbf43c83b922eacc6e9bf4c9 (diff)
downloadaur-785bc2c0514a29f50fedfeca9638da740d79ff3c.tar.gz
add spandsp docs.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD27
2 files changed, 28 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6a3cd5bf124..840156807374 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,11 +9,16 @@ pkgbase = spandsp-fs
makedepends = gawk
makedepends = sox
makedepends = fftw
- depends = libtiff
- provides = spandsp
- conflicts = spandsp
+ makedepends = doxygen
source = git+https://github.com/freeswitch/spandsp
sha256sums = SKIP
pkgname = spandsp-fs
+ depends = libtiff
+ optdepends = spandsp-docs: Documentation
+ provides = spandsp
+ conflicts = spandsp
+
+pkgname = spandsp-docs
+ pkgdesc = A DSP library for telephony documentation (FreeSWITCH version)
diff --git a/PKGBUILD b/PKGBUILD
index 57d4433c026f..a6999b5c0cde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,13 @@
# Maintainer: Clarence <xjh.azzbcc@gmail.com>
_pkgname=spandsp
-pkgname=${_pkgname}-fs
+pkgname=(${_pkgname}-fs ${_pkgname}-docs)
pkgver=3.0.0
pkgrel=1
pkgdesc="A DSP library for telephony (FreeSWITCH version)"
arch=('x86_64')
url="https://github.com/freeswitch/spandsp"
license=('LGPL' 'GPL')
-depends=('libtiff')
-makedepends=('gawk' 'sox' 'fftw')
-provides=('spandsp')
-conflicts=('spandsp')
+makedepends=('gawk' 'sox' 'fftw' 'doxygen')
source=("git+https://github.com/freeswitch/$_pkgname")
sha256sums=('SKIP')
@@ -22,7 +19,7 @@ pkgver() {
build() {
cd "$_pkgname"
./autogen.sh
- ./configure --prefix=/usr --enable-tests
+ ./configure --prefix=/usr --enable-tests --enable-doc
make -C src
}
@@ -31,8 +28,24 @@ check() {
make check
}
-package() {
+package_spandsp-fs() {
+ depends=('libtiff')
+ optdepends=('spandsp-docs: Documentation')
+ provides=('spandsp')
+ conflicts=('spandsp')
+
cd "$_pkgname"
make DESTDIR="$pkgdir" -C src install
make DESTDIR="$pkgdir" install-pkgconfigDATA
}
+
+package_spandsp-docs() {
+ pkgdesc="A DSP library for telephony documentation (FreeSWITCH version)"
+
+ cd "$_pkgname"
+ make -C doc
+
+ install -dm755 "${pkgdir}/usr/share/doc/$_pkgname/html"
+ cp -r "doc/api/html" "${pkgdir}/usr/share/doc/$_pkgname/html/api"
+ cp -r "doc/t38_manual" "${pkgdir}/usr/share/doc/$_pkgname/html/t38_manual"
+}