summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClarence2021-06-28 21:19:05 +0800
committerClarence2021-06-28 21:19:05 +0800
commite01ba7a45b3e6a04639f4db767d38dc0a622a706 (patch)
tree25580629afa5a9637abc08160392a483fe4a284a
parentb3f3bc106b6685e1045d31ca879c87a7525cbcf1 (diff)
downloadaur-e01ba7a45b3e6a04639f4db767d38dc0a622a706.tar.gz
disable doc build
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 9 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4bbaabed3bda..24a0f66015ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,17 +6,10 @@ pkgbase = spandsp-fs
arch = x86_64
license = LGPL
license = GPL
- makedepends = gawk
- makedepends = doxygen
- source = git+https://github.com/freeswitch/spandsp
- sha256sums = SKIP
-
-pkgname = spandsp-fs
depends = libtiff
- optdepends = spandsp-docs: Documentation
provides = spandsp
conflicts = spandsp
+ source = git+https://github.com/freeswitch/spandsp
+ sha256sums = SKIP
-pkgname = spandsp-docs
- pkgdesc = A DSP library for telephony documentation (FreeSWITCH version)
-
+pkgname = spandsp-fs
diff --git a/PKGBUILD b/PKGBUILD
index 400a70ad9c1f..b3f5d368079c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
# Maintainer: Clarence <xjh.azzbcc@gmail.com>
_pkgname=spandsp
-pkgname=(${_pkgname}-fs ${_pkgname}-docs)
+pkgname=${_pkgname}-fs
pkgver=3.0.0
pkgrel=1
pkgdesc="A DSP library for telephony (FreeSWITCH version)"
arch=('x86_64')
+depends=('libtiff')
+provides=('spandsp')
+conflicts=('spandsp')
url="https://github.com/freeswitch/spandsp"
license=('LGPL' 'GPL')
-makedepends=('gawk' 'doxygen')
source=("git+https://github.com/freeswitch/$_pkgname")
sha256sums=('SKIP')
@@ -19,33 +21,13 @@ pkgver() {
build() {
cd "$_pkgname"
./autogen.sh
- ./configure --prefix=/usr --disable-static --enable-doc
+ ./configure --prefix=/usr --disable-static
make -C src
}
-#
-#check() {
-# cd "$_pkgname"
-# make check
-#}
-
-package_spandsp-fs() {
- depends=('libtiff')
- optdepends=('spandsp-docs: Documentation')
- provides=('spandsp')
- conflicts=('spandsp')
+package() {
cd "$_pkgname"
make DESTDIR="$pkgdir" -C src install
make DESTDIR="$pkgdir" install-pkgconfigDATA
}
-package_spandsp-docs() {
- pkgdesc="A DSP library for telephony documentation (FreeSWITCH version)"
-
- cd "$_pkgname"
- make -C doc
-
- install -dm755 "${pkgdir}/usr/share/doc/$_pkgname/html"
- cp -r "doc/api/html" "${pkgdir}/usr/share/doc/$_pkgname/html/api"
- cp -r "doc/t38_manual" "${pkgdir}/usr/share/doc/$_pkgname/html/t38_manual"
-}