summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmish2018-03-12 23:52:41 +0530
committerAmish2018-03-12 23:52:41 +0530
commit6075d6e5e0b34acfbebef7227a5af613f173bffb (patch)
treeb99f76c0441721c5ba535eb25c27deae4aa9b87f
parent691e745dc7e5cf5b4ca632cde8993d20e11b4aaa (diff)
downloadaur-6075d6e5e0b34acfbebef7227a5af613f173bffb.tar.gz
Use deb archive without JRE (uses Arch JRE)
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 21 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a986b5c443a0..127fa9c87312 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = spark
pkgdesc = Cross-platform real-time collaboration client optimized for business and organizations.
pkgver = 2.8.3
- pkgrel = 0
+ pkgrel = 2
url = http://www.igniterealtime.org/projects/spark/
- arch = i686
- arch = x86_64
+ arch = any
license = LGPL
+ depends = java-runtime
+ depends = unixodbc
+ depends = libxtst
conflicts = spark-svn
options = !strip
- source = http://download.igniterealtime.org/spark/spark_2_8_3.tar.gz
- md5sums = 9efe43a337789bfa6083b341a48e9e53
+ source = http://download.igniterealtime.org/spark/spark_2_8_3.deb
+ md5sums = 12335bc5cbf223f128e44da44b620942
pkgname = spark
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..67dd95ad6885
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*any.pkg.tar.xz
+spark*.deb
diff --git a/PKGBUILD b/PKGBUILD
index 05d1cdd8ffee..ecd6d6677785 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,23 @@
-# Maintainer: ArthurBorsboom <arthurborsboom@gmail.com>
+# Maintainer: Amish <contact at via dot aur>
+# Contributor: ArthurBorsboom <arthurborsboom@gmail.com>
# Contributor: Sirat18 <aur@sirat18.de>
# Contributor: markelos <axilleas@archlinux.gr>
# Contributor: helios <aur@wiresphere.de>
pkgname=spark
pkgver=2.8.3
-pkgrel=0
+pkgrel=2
pkgdesc="Cross-platform real-time collaboration client optimized for business and organizations."
-arch=('i686' 'x86_64')
+arch=('any')
url="http://www.igniterealtime.org/projects/spark/"
license=('LGPL')
-if [[ $CARCH == x86_64 ]]; then
- depends=('java-runtime' 'unixodbc')
-fi
-if [[ $CARCH == i686 ]]; then
- depends=('java-runtime' 'unixodbc')
-fi
+depends=('java-runtime' 'unixodbc' 'libxtst')
options=('!strip')
-source=(http://download.igniterealtime.org/${pkgname}/${pkgname}_${pkgver//./_}.tar.gz)
-md5sums=('9efe43a337789bfa6083b341a48e9e53')
-
+source=(http://download.igniterealtime.org/${pkgname}/${pkgname}_${pkgver//./_}.deb)
+md5sums=('12335bc5cbf223f128e44da44b620942')
conflicts=('spark-svn')
package() {
- cd "$srcdir"
- sed -i 's/\\lib\\windows/lib\/linux/g' Spark/Spark
-
- install -d -m755 "${pkgdir}"/opt/spark
- cp -R Spark/. $pkgdir/opt/spark
-
- install -d -m755 "${pkgdir}"/usr/bin
- ln -fs /opt/spark/Spark $pkgdir/usr/bin/spark
+ cd "${srcdir}"
+ msg2 "Extracting the data.tar.xz..."
+ bsdtar -C "${pkgdir}" -xf data.tar.xz
}