summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornytpu2023-03-18 08:50:30 -0600
committernytpu2023-03-18 08:50:30 -0600
commit8834299bed16054233ea475b451bc4356e7cdb84 (patch)
tree7be8d416f49fe5c36144957e793febd01891009e
parent98c9dbffe6b10128353682a4b329bd0247f31d99 (diff)
downloadaur-spark2014-git.tar.gz
upgpkg: spark2014-git 0.3.draft.r23092.g3e6f33a5e9-1
spark2014-git: fix building on recent versions
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--build-flags.patch12
-rw-r--r--makefile-fixes.patch13
4 files changed, 34 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 613369d8ce67..8ba1b7bfcd13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spark2014-git
pkgdesc = Formally defined programming language based on Ada (GNAT FSF version)
- pkgver = 0.3.draft.r23009.gcf9fcdf75f
+ pkgver = 0.3.draft.r23092.g3e6f33a5e9
pkgrel = 1
url = https://www.spark-2014.org
arch = x86_64
@@ -30,9 +30,11 @@ pkgbase = spark2014-git
source = why3-adacore::git+https://github.com/AdaCore/why3
source = git+https://github.com/gcc-mirror/gcc
source = makefile-fixes.patch
+ source = build-flags.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 9985b6864849fb0210cdf40d64b7747cac2c8371385f9790b142d402b5b7d22a
+ sha256sums = 4ba7b439be23cde5612f743fd552774f43312fdfacd64fb0c98b9b6a9f78f6b2
+ sha256sums = 55d433193028ffce792e622eb54d9f206c441e1bdecb9492ccfef04843e62142
pkgname = spark2014-git
diff --git a/PKGBUILD b/PKGBUILD
index f789bc09b79b..651827861803 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# https://git.sr.ht/~nytpu/PKGBUILDs/
pkgname=spark2014-git
-pkgver=0.3.draft.r23009.gcf9fcdf75f
+pkgver=0.3.draft.r23092.g3e6f33a5e9
pkgrel=1
pkgdesc='Formally defined programming language based on Ada (GNAT FSF version)'
url='https://www.spark-2014.org'
@@ -31,11 +31,13 @@ conflicts=('spark2014')
source=('git+https://github.com/AdaCore/spark2014#branch=fsf'
'why3-adacore::git+https://github.com/AdaCore/why3'
'git+https://github.com/gcc-mirror/gcc'
- 'makefile-fixes.patch')
+ 'makefile-fixes.patch'
+ 'build-flags.patch')
sha256sums=('SKIP' 'SKIP' 'SKIP'
- '9985b6864849fb0210cdf40d64b7747cac2c8371385f9790b142d402b5b7d22a')
+ '4ba7b439be23cde5612f743fd552774f43312fdfacd64fb0c98b9b6a9f78f6b2'
+ '55d433193028ffce792e622eb54d9f206c441e1bdecb9492ccfef04843e62142')
prepare() {
cd spark2014
@@ -49,6 +51,7 @@ prepare() {
# Use install instead of mv to install the various targets while also
# houring the INSTALLDIR convention used within this Makefile.
patch -Np2 -i "${srcdir}/makefile-fixes.patch"
+ patch -Np2 -i "${srcdir}/build-flags.patch"
# Arch Linux doesn't use libexec, everything lives under lib.
sed -i 's/libexec/lib/g' src/gnatprove/configuration.ads
@@ -62,6 +65,10 @@ pkgver() {
build() {
cd spark2014
+
+ CFLAGS="${CFLAGS//-Wformat}"
+ CFLAGS="${CFLAGS//-Werror=format-security}"
+
make setup INSTALLDIR="${pkgdir}/usr"
make
make -C docs/lrm man
diff --git a/build-flags.patch b/build-flags.patch
new file mode 100644
index 000000000000..11dfe2254f17
--- /dev/null
+++ b/build-flags.patch
@@ -0,0 +1,12 @@
+diff --color --unified --recursive --text src.orig/spark2014/gnat2why/gnat2why_gnat.gpr src/spark2014/gnat2why/gnat2why_gnat.gpr
+--- src.orig/spark2014/gnat2why/gnat2why_gnat.gpr 2023-03-18 08:10:41.804020508 -0600
++++ src/spark2014/gnat2why/gnat2why_gnat.gpr 2023-03-18 08:11:36.097357323 -0600
+@@ -13,7 +13,7 @@
+
+ Build : Build_Type := External ("Build", "Devel");
+
+- Common_Switches := ("-g", "-gnat2022");
++ Common_Switches := ("-g", "-gnat2022", "-gnatwU");
+ -- These are appended after other switches, in particular, after -gnatg,
+ -- which sets the Ada version to 2012.
+
diff --git a/makefile-fixes.patch b/makefile-fixes.patch
index 5ac4bf219ad7..cfc19d7bd934 100644
--- a/makefile-fixes.patch
+++ b/makefile-fixes.patch
@@ -1,7 +1,7 @@
-diff --color --unified --recursive --text src.orig/spark2014/Makefile src.new/spark2014/Makefile
---- src.orig/spark2014/Makefile 2022-05-12 14:41:28.440880794 -0600
-+++ src.new/spark2014/Makefile 2022-05-12 14:44:29.869703151 -0600
-@@ -77,9 +77,9 @@
+diff --color --unified --recursive --text src.orig/spark2014/Makefile src/spark2014/Makefile
+--- src.orig/spark2014/Makefile 2023-03-18 08:37:08.487455631 -0600
++++ src/spark2014/Makefile 2023-03-18 08:39:01.057462841 -0600
+@@ -78,9 +78,9 @@
# install-all install of gnatprove and why3
setup:
@@ -13,9 +13,12 @@ diff --color --unified --recursive --text src.orig/spark2014/Makefile src.new/sp
why3:
$(MAKE) -C why3 -j $(nproc)
-@@ -89,7 +89,7 @@
+@@ -89,9 +89,9 @@
+ install-all:
$(MAKE) install
$(MAKE) -C why3 install_spark2014_dev
+- sha256sum install/libexec/spark/bin/gnatwhy3 | cut -d' ' -f1 > install/libexec/spark/bin/gnatwhy3.hash
++ sha256sum $(INSTALLDIR)/lib/spark/bin/gnatwhy3 | cut -d' ' -f1 > $(INSTALLDIR)/lib/spark/bin/gnatwhy3.hash
# Create the fake prover scripts to help extract benchmarks.
- $(CP) benchmark_script/fake_* install/libexec/spark/bin
+ $(CP) benchmark_script/fake_* $(INSTALLDIR)/lib/spark/bin