summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornytpu2022-11-26 23:02:42 -0700
committernytpu2022-11-26 23:02:42 -0700
commit89c7580c0fd0d639458ede34c9ad1e387f9d16cc (patch)
treeed14f207daaa93c4dfd82a482c7d55316b874b9b
parent1cc97e59952095bc64588acd3894298a704821b4 (diff)
downloadaur-89c7580c0fd0d639458ede34c9ad1e387f9d16cc.tar.gz
upgpkg: spark2014-git 0.3.draft.r22985.g5631f0e48f-1
Fix issue with loading git submodule from local directory
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ff38315a94fd..9075e977cbc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -41,7 +41,7 @@ prepare() {
cd spark2014
git submodule init
git config submodule.why3.url "${srcdir}/why3-adacore"
- git submodule update why3
+ git -c protocol.file.allow=always submodule update why3
cd why3 && git reset --hard && cd ..
ln -sf "${srcdir}/gcc/gcc/ada" gnat2why/gnat_src