summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2012-10-31 04:17:25 +0000
committerBalló György2012-10-31 04:17:25 +0000
commite1b06e782ac5ea263ee749fbe8aa5b25c2c9f692 (patch)
tree0bd3ba72f88a0aca1c1b1a867544d56b5076fc22
parentd5b0eaad0d9ab0d6b4014a2855f1fc2742f99782 (diff)
downloadaur-e1b06e782ac5ea263ee749fbe8aa5b25c2c9f692.tar.gz
Update to version 0.9.6
-rw-r--r--PKGBUILD21
-rw-r--r--fix-crash.patch24
2 files changed, 6 insertions, 39 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9da4cb6b90b6..fa3bf350d1f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,33 +3,24 @@
# Contributor: Erdbeerkaese <erdbeerkaese underscore arch at gmail dot com>
pkgname=sparkleshare
-pkgver=0.9.3
-pkgrel=2
+pkgver=0.9.6
+pkgrel=1
pkgdesc="Collaboration and sharing tool based on git written in C Sharp"
arch=('any')
url="http://sparkleshare.org/"
license=('GPL3')
depends=('webkit-sharp' 'notify-sharp' 'curl' 'git' 'openssh' 'desktop-file-utils' 'hicolor-icon-theme' 'xdg-utils')
-makedepends=('intltool' 'gnome-doc-utils' 'python2-nautilus')
-optdepends=('python2-nautilus: Nautilus extension')
+makedepends=('intltool' 'gnome-doc-utils')
install=$pkgname.install
-source=(https://github.com/downloads/hbons/SparkleShare/$pkgname-linux-$pkgver.tar.gz
- fix-crash.patch)
-md5sums=('58d1f5141385bad13cc004d32b095eef'
- '51ec7e3c090be69864f95227fd7abae6')
+source=(https://github.com/downloads/hbons/SparkleShare/$pkgname-linux-$pkgver.tar.gz)
+md5sums=('a7527607e8fd9c2968cdb55ce640d132')
build() {
cd "$srcdir/$pkgname-$pkgver"
- # https://github.com/hbons/SparkleShare/issues/965
- patch -Np1 -i "$srcdir/fix-crash.patch"
-
- # Python2 fix
- sed -i 's|#!/usr/bin/python|#!/usr/bin/python2|' SparkleShare/Linux/Nautilus/sparkleshare-nautilus3-extension.py.in
-
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--disable-appindicator
- make -j1
+ make
}
package() {
diff --git a/fix-crash.patch b/fix-crash.patch
deleted file mode 100644
index bf435418e592..000000000000
--- a/fix-crash.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Naur sparkleshare-0.9.3.orig/SparkleShare/Linux/SparkleSetup.cs sparkleshare-0.9.3/SparkleShare/Linux/SparkleSetup.cs
---- sparkleshare-0.9.3.orig/SparkleShare/Linux/SparkleSetup.cs 2012-09-15 12:18:05.000000000 +0200
-+++ sparkleshare-0.9.3/SparkleShare/Linux/SparkleSetup.cs 2012-10-16 19:14:13.226364167 +0200
-@@ -65,14 +65,16 @@
- Xalign = 1
- };
-
-- string username = UnixUserInfo.GetRealUser ().RealName;
-- username = username.TrimEnd (",".ToCharArray ());
--
-- Entry name_entry = new Entry (username) {
-+ Entry name_entry = new Entry () {
- Xalign = 0,
- ActivatesDefault = true
- };
-
-+ UnixUserInfo user_info = UnixUserInfo.GetRealUser ();
-+
-+ if (user_info != null && user_info.RealName != null)
-+ name_entry.Text = user_info.RealName.TrimEnd (",".ToCharArray ());
-+
- Entry email_entry = new Entry () {
- Xalign = 0,
- ActivatesDefault = true