summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerome Leclanche2015-06-10 00:00:24 +0200
committerJerome Leclanche2015-06-10 00:00:24 +0200
commit3cbac93cbf3a85a1f3c4cc905489cfa749c5ab34 (patch)
treed24ec1fbad2bf155b89b9ba46e0ded2befdb1a8b
downloadaur-3cbac93cbf3a85a1f3c4cc905489cfa749c5ab34.tar.gz
Initial import from old AUR
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83e6ba5f84c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sparklines-git
+ pkgdesc = Spark: Sparklines for your shell
+ pkgver = v1.0.1.6.g9832447
+ pkgrel = 1
+ url = http://zachholman.com/spark/
+ arch = any
+ license = MIT
+ makedepends = git
+ provides = sparklines
+ conflicts = sparklines
+ source = git://github.com/holman/spark.git
+ sha256sums = SKIP
+
+pkgname = sparklines-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4b5a4f8509f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+# NOTE: This package is officially named "spark", however that name
+# conflicts with the Spark IM client. It is here renamed sparklines.
+
+_pkgname=spark
+pkgname=sparklines-git
+pkgver=v1.0.1.6.g9832447
+pkgrel=1
+pkgdesc="Spark: Sparklines for your shell"
+arch=('any')
+url="http://zachholman.com/spark/"
+license=('MIT')
+makedepends=('git')
+provides=('sparklines')
+conflicts=('sparklines')
+source=("git://github.com/holman/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s/-/./g"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -D spark "$pkgdir/usr/bin/sparklines"
+ install -D "README.md" "$pkgdir/usr/share/doc/spark/README.md"
+}